summaryrefslogtreecommitdiff
path: root/dev-libs/libutf8proc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-libs/libutf8proc/files
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-libs/libutf8proc/files')
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch21
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch33
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-grapheme-test.patch23
3 files changed, 23 insertions, 54 deletions
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
deleted file mode 100644
index 75e9eaac6b53..000000000000
--- a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-no-static.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/Makefile b/Makefile
-index e3310f7..44c8977 100644
---- a/Makefile
-+++ b/Makefile
-@@ -46,7 +46,7 @@ pkgincludedir=$(includedir:$(prefix)/%=%)
-
- .PHONY: all clean data update manifest install
-
--all: libutf8proc.a libutf8proc.$(SHLIB_EXT)
-+all: libutf8proc.$(SHLIB_EXT)
-
- clean:
- rm -f utf8proc.o libutf8proc.a libutf8proc.$(SHLIB_VERS_EXT) libutf8proc.$(SHLIB_EXT)
-@@ -104,7 +104,6 @@ install: libutf8proc.a libutf8proc.$(SHLIB_EXT) libutf8proc.$(SHLIB_VERS_EXT) li
- mkdir -m 755 -p $(DESTDIR)$(includedir)
- $(INSTALL) -m 644 utf8proc.h $(DESTDIR)$(includedir)
- mkdir -m 755 -p $(DESTDIR)$(libdir)
-- $(INSTALL) -m 644 libutf8proc.a $(DESTDIR)$(libdir)
- $(INSTALL) -m 755 libutf8proc.$(SHLIB_VERS_EXT) $(DESTDIR)$(libdir)
- mkdir -m 755 -p $(DESTDIR)$(pkgconfigdir)
- $(INSTALL) -m 644 libutf8proc.pc $(DESTDIR)$(pkgconfigdir)/libutf8proc.pc
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
deleted file mode 100644
index f438fdd9779b..000000000000
--- a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/data/Makefile b/data/Makefile
-index f5d1dd9..60c09e3 100644
---- a/data/Makefile
-+++ b/data/Makefile
-@@ -10,6 +10,7 @@ PERL=perl
- MAKE=make
- JULIA=julia
- CURLFLAGS = --retry 5 --location
-+UDATA=${EPREFIX}/usr/share/unicode-data
-
- .PHONY: clean
-
-@@ -25,6 +26,7 @@ CharWidths.txt: charwidths.jl EastAsianWidth.txt
- UNICODE_VERSION=12.0.0
-
- UnicodeData.txt:
-+ cp $(UDATA)/$@ $@
- $(CURL) $(CURLFLAGS) -o $@ -O http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/UnicodeData.txt
-
- EastAsianWidth.txt:
-@@ -43,10 +45,10 @@ CaseFolding.txt:
- $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/CaseFolding.txt
-
- NormalizationTest.txt:
-- $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/NormalizationTest.txt
-+ cp $(UDATA)/$@ $@
-
- GraphemeBreakTest.txt:
-- $(CURL) $(CURLFLAGS) $(URLCACHE)http://www.unicode.org/Public/$(UNICODE_VERSION)/ucd/auxiliary/GraphemeBreakTest.txt | $(PERL) -pe 's,÷,/,g;s,×,+,g' > $@
-+ cat $(UDATA)/auxiliary/$@ | $(PERL) -pe 's,÷,/,g;s,×,+,g' > $@
-
- emoji-data.txt:
- $(CURL) $(CURLFLAGS) -o $@ -O $(URLCACHE)http://unicode.org/Public/emoji/`echo $(UNICODE_VERSION) | cut -d. -f1-2`/emoji-data.txt
diff --git a/dev-libs/libutf8proc/files/libutf8proc-grapheme-test.patch b/dev-libs/libutf8proc/files/libutf8proc-grapheme-test.patch
new file mode 100644
index 000000000000..64ebc26f671e
--- /dev/null
+++ b/dev-libs/libutf8proc/files/libutf8proc-grapheme-test.patch
@@ -0,0 +1,23 @@
+https://github.com/JuliaStrings/utf8proc/commit/11bb3d9dc796bb006c79c2962a7d19abcadfb3df
+
+Author: Steven G. Johnson <stevenj@alum.mit.edu>
+
+--- a/test/graphemetest.c
++++ b/test/graphemetest.c
+@@ -18,12 +18,12 @@ int main(int argc, char **argv)
+
+ while (buf[bi]) {
+ bi = skipspaces(buf, bi);
+- if (buf[bi] == '/') { /* grapheme break */
++ if ((uint8_t)buf[bi] == 0xc3 && (uint8_t)buf[bi+1] == 0xb7) { /* U+00f7 = grapheme break */
+ src[si++] = '/';
+- bi++;
++ bi += 2;
+ }
+- else if (buf[bi] == '+') { /* no break */
+- bi++;
++ else if ((uint8_t)buf[bi] == 0xc3 && (uint8_t)buf[bi+1] == 0x97) { /* U+00d7 = no break */
++ bi += 2;
+ }
+ else if (buf[bi] == '#') { /* start of comments */
+ break;