summaryrefslogtreecommitdiff
path: root/dev-libs/libuev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-09 09:14:02 +0000
commitb9ef7cab6264f1838672efbbcb4ba3b3abd5323f (patch)
tree38e677f4a13244ca8ed29a815a0a62f943b430d4 /dev-libs/libuev
parentd37b97a25b8b10f748eead6574b01f893f140b01 (diff)
gentoo resync : 09.12.2017
Diffstat (limited to 'dev-libs/libuev')
-rw-r--r--dev-libs/libuev/Manifest3
-rw-r--r--dev-libs/libuev/libuev-2.1.0.ebuild23
-rw-r--r--dev-libs/libuev/metadata.xml20
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libuev/Manifest b/dev-libs/libuev/Manifest
new file mode 100644
index 000000000000..013e978dc4e2
--- /dev/null
+++ b/dev-libs/libuev/Manifest
@@ -0,0 +1,3 @@
+DIST libuev-2.1.0.tar.xz 247388 BLAKE2B e2934fb79e32bf61e22a7c8fcdd6371f089c5e8a4f5b3039c10c90abd852d08c5612f7b871ef705afdca68857a270dfd133a1436cd9f49876e0bf47b903e6328 SHA512 82bd68c75f015284d3757886720d1a0e5689cf71b40b896410e5e4e952761fe05b090a33e0787f632afa7726567667e4dbbbc6270129828656953ded6d28d02b
+EBUILD libuev-2.1.0.ebuild 534 BLAKE2B 4150427bd0e11f554676c94e81e83133558c64295861e0d0ad126f4800f7546e86aa24709754aee3d766d6228f9aac25990a9d5c572c6d507ae57d820b198a5e SHA512 da87d2ddac8efd98e103319718bc62e4737b2c8609df22b8f7064ccc66ddd10d003f7aee299c8a898658f4ce22a0e8feaaae1d1e220c0a0d59b710a2ae32e286
+MISC metadata.xml 697 BLAKE2B dcba433b09e4af6c7a3e849ec4b084545f84d08faa409b7408ae95d3f2922632f08237b6c51e1274a09299b0b09cb2031d809a8f5957f75206573695e7a9b11e SHA512 5250db4faa8c97ffb7b2a7df81b1afd4300358e2f223e1dcb15e461521c816abb09aac8c333315e506c325464ea404a4651009ce2f82b7a1270cbb35020cd4ff
diff --git a/dev-libs/libuev/libuev-2.1.0.ebuild b/dev-libs/libuev/libuev-2.1.0.ebuild
new file mode 100644
index 000000000000..299e8c4aa126
--- /dev/null
+++ b/dev-libs/libuev/libuev-2.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libuev"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure(){
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install(){
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}
diff --git a/dev-libs/libuev/metadata.xml b/dev-libs/libuev/metadata.xml
new file mode 100644
index 000000000000..55df3087918b
--- /dev/null
+++ b/dev-libs/libuev/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ libuEv is a simple event loop in the style of the more established
+ libevent, libev and the venerable Xt(3) event loop. The u (micro) in the
+ name refers to both the small feature set and the small size overhead
+ impact of the library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">troglobit/libuev</remote-id>
+ </upstream>
+</pkgmetadata>