summaryrefslogtreecommitdiff
path: root/dev-libs/libucl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libucl
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libucl')
-rw-r--r--dev-libs/libucl/Manifest4
-rw-r--r--dev-libs/libucl/libucl-0.7.3.ebuild45
-rw-r--r--dev-libs/libucl/metadata.xml23
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/libucl/Manifest b/dev-libs/libucl/Manifest
new file mode 100644
index 000000000000..f470a38d4745
--- /dev/null
+++ b/dev-libs/libucl/Manifest
@@ -0,0 +1,4 @@
+DIST libucl-0.7.3.tar.gz 1986726 SHA256 2f69995c7f8320350f56c1183c395cc4a2a958331f22d60b7839a117c9c601e1 SHA512 29b466254887f7be1168ce31de9f852f3f1868a3afaa5a73859a4cd43b915510850e786ff778613fa48579ee6f0f78e5898c83ce9423f1fb688cce8d969a8eab WHIRLPOOL 2f72d5a5b938719f59661abe827cfc7f0b20db22c478fdc98c40d664c652d0b67096aa82b5ec161d3212bfd38924b3be364bd797ea090ec620f7c2efc82a4157
+EBUILD libucl-0.7.3.ebuild 973 SHA256 bb5c80f7f2970de98eca5855d6977f7c22fa5ecafd6abf466f127bec927ccfac SHA512 ccf1dfb8d53df0009a21c25b18855bfacfa7dd922083b67d6d116e6021963aaa513bd000f78baa6ffa7204918a62ac6689eb7dc16429920ac54158578679a1d9 WHIRLPOOL afab2d59987d86b0c2870099b557578ba3b37b21d2831ad4017fda01ed19dc52b97c79c3084882d85f5f924044ecde46ea974cacad32075f9250d6afefdd8662
+MISC ChangeLog 1224 SHA256 13c998a8370a5acfa18d2d552161fa5970d74d1c0f3ecaf3e87efd0fc25acf84 SHA512 37dd68193bd4b8d1d8e37188da63afaa334f799f7316e2cc5b670f70548b38f06adbf60804cd7e68a199c17492be5a2dabe8514413d690b6808aeb280ab1116c WHIRLPOOL bc19645dcc473d1e18f06b5ee975c500a16ed8703d846a476f48fae9cba3f46450c1ad9af42d98567a004dbef6a69ebf43d3df8d0732a1874a766bb4ee078003
+MISC metadata.xml 910 SHA256 92bf2c279d7b808701f76e13cc6878cd3a87c62172f4e2122f10235bf2e5a887 SHA512 30aa6e64758a43680a6893516a1902b774d636b671e4191babafa10be4154c2f62da45249109727a7cbf9b9f203e0f97290a3dea70934faf403b7828c6b89a8e WHIRLPOOL 31f954be0ce9bc53d13f2942f30e865ea419e64963763baf322bc50fbb3e396e858a1c8361e0ae59f756afdab6b58491ab7cd2589b9f500a3f4900319ba218f6
diff --git a/dev-libs/libucl/libucl-0.7.3.ebuild b/dev-libs/libucl/libucl-0.7.3.ebuild
new file mode 100644
index 000000000000..14a8f7579a58
--- /dev/null
+++ b/dev-libs/libucl/libucl-0.7.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Universal configuration library parser"
+HOMEPAGE="https://github.com/vstakhov/libucl"
+SRC_URI="https://github.com/vstakhov/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="lua +regex signatures static-libs urlfetch utils"
+DEPEND="!!dev-libs/ucl
+ lua? ( >=dev-lang/lua-5.1:= )
+ signatures? ( dev-libs/openssl:0 )
+ urlfetch? ( net-misc/curl )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md doc/api.md )
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local myeconf=""
+ use urlfetch && myeconf="--with-urls"
+ econf \
+ $(use_enable lua) \
+ $(use_enable regex) \
+ $(use_enable signatures) \
+ $(use_enable utils) \
+ ${myeconf}
+}
+
+src_install() {
+ default
+ use lua && DOCS+=( doc/lua_api.md )
+ # no .a's it seems
+ use static-libs || find "${ED}" -name "*.la" -delete
+}
diff --git a/dev-libs/libucl/metadata.xml b/dev-libs/libucl/metadata.xml
new file mode 100644
index 000000000000..6d4d014359bc
--- /dev/null
+++ b/dev-libs/libucl/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ UCL is heavily infused by nginx configuration as the example of a
+ convenient configuration system. However, UCL is fully compatible
+ with JSON format and is able to parse json files. It can also emit
+ UCL objects into different formats such as "nginx like", json,
+ yaml and compact json
+ </longdescription>
+ <use>
+ <flag name="regex">Enable regex checking for schema</flag>
+ <flag name="signatures">Enable signatures check</flag>
+ <flag name="urlfetch">Enable URLs fetch</flag>
+
+ <!-- in v0.8.0, also the ucl-tool utility -->
+ <flag name="utils">Install the chargen and objdump utilities</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">vstakhov/libucl</remote-id>
+ </upstream>
+</pkgmetadata>