summaryrefslogtreecommitdiff
path: root/dev-libs/libucl/libucl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-libs/libucl/libucl-9999.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-libs/libucl/libucl-9999.ebuild')
-rw-r--r--dev-libs/libucl/libucl-9999.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/dev-libs/libucl/libucl-9999.ebuild b/dev-libs/libucl/libucl-9999.ebuild
index c4c4911fe043..66e66cd2dc80 100644
--- a/dev-libs/libucl/libucl-9999.ebuild
+++ b/dev-libs/libucl/libucl-9999.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-inherit autotools
+LUA_COMPAT=( lua5-{1..3} )
+inherit lua-single autotools
DESCRIPTION="Universal configuration library parser"
HOMEPAGE="https://github.com/vstakhov/libucl"
@@ -18,11 +19,12 @@ fi
LICENSE="BSD-2"
SLOT="0"
-
-IUSE="lua +regex sign urls +utils static-libs"
+IUSE="lua +regex sign urls +utils static-libs test"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
DEPEND="!!dev-libs/ucl
- lua? ( >=dev-lang/lua-5.1:= )
+ lua? ( ${LUA_DEPS} )
urls? ( net-misc/curl )
sign? ( dev-libs/openssl:0 )
"
@@ -36,24 +38,31 @@ DOCS=( README.md doc/api.md )
src_prepare() {
default
rm tests/schema/{definitions,ref{,Remote}}.json || die
-
eautoreconf
}
src_configure() {
+ lua_setup
+
local myeconfargs=(
"$(use_enable lua)"
"$(use_enable regex)"
"$(use_enable sign signatures)"
"$(use_enable urls)"
"$(use_enable utils)"
+ LUA_INCLUDE="$(lua_get_CFLAGS)"
+ LIB_LIBS="$(lua_get_LIBS)"
)
- econf "${myeconfargs}"
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake check
}
src_install() {
default
- DOCS+=( $(usex lua "doc/lua_api.md" "") )
+ use lua && DOCS+=( "doc/lua_api.md" )
einstalldocs
if ! use static-libs; then
find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || \