summaryrefslogtreecommitdiff
path: root/dev-libs/libtpms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-libs/libtpms
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-libs/libtpms')
-rw-r--r--dev-libs/libtpms/Manifest2
-rw-r--r--dev-libs/libtpms/libtpms-0.9.5.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index 8624c2adeab1..f8f60df4a867 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1,4 +1,6 @@
AUX libtpms-0.9.0-Remove-WError.patch 508 BLAKE2B 33178598a1fef1189039c30814996f00ec37215b3f10a0ff9df521a866147b2a6844d86c3b372e450f701e6e2ae3e587443765c39848076536861342e5b42d63 SHA512 e0d55045bcb667278dc1ae1c509b7be466f23421683f8b0b7c830d724f83b1923b09a61f2a8e649e08150d1d313f0456cfc5f5a1b5fe3bf168565e443595dd12
DIST libtpms-0.9.4.tar.gz 1264030 BLAKE2B 56731b913145afcd49fae13f0fcbe4fc147edf206a44849cef45ed34a7644f0894bb6ab5dcb72d620eb1ab121bf4e821fe7893557508af394585171133d659e2 SHA512 ae3e2613bc31d98c10def546c70d0c25bd1246af5090268afa0411502bfd0e454967046ebcd9025350976817441e595fa4e21562f800285db98331e4c2743505
+DIST libtpms-0.9.5.tar.gz 1264086 BLAKE2B 3e6da08dd31414bdf19260f47fce6ba7ace0ae72b152b681f1c1fbc9d75b7708238e5c2a161827c7a6e2b9a6ae4786dfbf921ec37b9f0b7c044835c974a111a3 SHA512 96b8d6dd66a6c4bc7b72d172d0b75444c7725a7fb5b0f792cd1cff9d8f7ec894c51e94493816f033198cc8adf2f95cf473629431dadb70b423068d834de09e21
EBUILD libtpms-0.9.4.ebuild 1299 BLAKE2B 6c78609afdc5385a842da2f415ef918475baab3da737cb2e43c72cf5d2aaa382dd84b4157e4b52aa7fa5f44de6db48b37f680897baabb006d923589d4ca39552 SHA512 f54857978f2f4d021055406f2f2f480f3df97ca57cf29b1967389107079cbe37551ac8717c03fdbf38cb4aa64b5567a87f27bd2ed46edd0243d076c06689f3b1
+EBUILD libtpms-0.9.5.ebuild 1304 BLAKE2B a59602976b1c6564c1a75dd97418dc35c9537e4adc997e8a6ac63ec833a9d8d4e154425d9ea82311cbadade514a26a60e8c5b7ae2008f434c1b9ee0568c239b8 SHA512 59fe0fa80df39422df62858552384ae88613a7d037ec1ac9de3687d80959903a3d422c11fd6f6ac196eab9d75573003ca9f2adca59d28f1034e8d7a619b43d31
MISC metadata.xml 536 BLAKE2B 75236814e21cb3e98feaa2646ccf680973a71e168d5ccd95cdd12f06214a1b18454cb40b1825df9335e3c4881b7d8d3cffdf03c48dcedd99da4a0dd50d81fe1b SHA512 3abebe84fc62f5082d22e0a3d146a22e7e799d0b1d0f3cfa282aac408ca8c0b8f396f7b081c92aec290037bb7405e672ce7f6f4f8da5b1966a0b4eda8005d721
diff --git a/dev-libs/libtpms/libtpms-0.9.5.ebuild b/dev-libs/libtpms/libtpms-0.9.5.ebuild
new file mode 100644
index 000000000000..fc15af9bf0f4
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.8.0; then
+ elog "Versions of libtpms prior to 0.8.0 generate weaker than expected TPM 2.0 RSA"
+ elog "keys due to a flawed key creation algorithm. Because fixing this would render"
+ elog "existing sealed data inaccessible, to use the corrected algorithm, the old"
+ elog "TPM state file must be deleted and a new TPM state file created. Data still"
+ elog "sealed using the old state file will be permanently inaccessible. For the"
+ elog "details see https://github.com/stefanberger/libtpms/issues/183"
+ fi
+}