summaryrefslogtreecommitdiff
path: root/dev-libs/libtpms/libtpms-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-libs/libtpms/libtpms-0.7.0.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-libs/libtpms/libtpms-0.7.0.ebuild')
-rw-r--r--dev-libs/libtpms/libtpms-0.7.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/libtpms/libtpms-0.7.0.ebuild b/dev-libs/libtpms/libtpms-0.7.0.ebuild
new file mode 100644
index 000000000000..ea28c3dd94fe
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl \
+ --with-tpm2
+}