summaryrefslogtreecommitdiff
path: root/dev-libs/libtecla/libtecla-1.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libtecla/libtecla-1.6.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libtecla/libtecla-1.6.3.ebuild')
-rw-r--r--dev-libs/libtecla/libtecla-1.6.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libtecla/libtecla-1.6.3.ebuild b/dev-libs/libtecla/libtecla-1.6.3.ebuild
new file mode 100644
index 000000000000..954e62a71a87
--- /dev/null
+++ b/dev-libs/libtecla/libtecla-1.6.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Tecla command-line editing library"
+HOMEPAGE="http://www.astro.caltech.edu/~mcs/tecla/"
+SRC_URI="http://www.astro.caltech.edu/~mcs/tecla/${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/libtecla
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-install.patch
+ "${FILESDIR}"/${PN}-1.6.1-no-strip.patch
+ "${FILESDIR}"/${PN}-1.6.3-ldflags.patch
+ "${FILESDIR}"/${PN}-1.6.3-prll-build.patch
+ "${FILESDIR}"/${PN}-1.6.1-prll-install.patch
+ "${FILESDIR}"/${PN}-1.6.3-static-libs.patch
+ "${FILESDIR}"/${PN}-1.6.3-secure-runpath.patch
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs)
+}
+
+src_compile() {
+ emake \
+ OPT="" \
+ LDFLAGS="${LDFLAGS}" \
+ LFLAGS="$(raw-ldflags)"
+}