summaryrefslogtreecommitdiff
path: root/dev-libs/libstrophe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /dev-libs/libstrophe
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'dev-libs/libstrophe')
-rw-r--r--dev-libs/libstrophe/Manifest4
-rw-r--r--dev-libs/libstrophe/files/libstrophe-0.9.2-libressl.patch20
-rw-r--r--dev-libs/libstrophe/libstrophe-0.9.2.ebuild46
-rw-r--r--dev-libs/libstrophe/metadata.xml17
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/Manifest b/dev-libs/libstrophe/Manifest
new file mode 100644
index 000000000000..68ff6679eda1
--- /dev/null
+++ b/dev-libs/libstrophe/Manifest
@@ -0,0 +1,4 @@
+AUX libstrophe-0.9.2-libressl.patch 843 BLAKE2B f979127225535d271dafdb379d9e07bdfd06cd5684c07fe2a8a466698109dd68c0626615d20636d230858e5a2868dd450b5fabcbb4482e6814a2b3d032bd89f8 SHA512 6a6321955805eb1b80a7dc6baa528a9594f2d37a640e4166839fa9db9d0e2113a64dd33f08682c03a1a840836c76a4e62e384c9cfdd798442ee024ff88c1d8e6
+DIST libstrophe-0.9.2.tar.gz 500459 BLAKE2B 0b1f6f1daac1215bcdcbde0e54264b98f5a863de339500826f625f8c5e8143ce7200fb251d04248715e9a8b6621a4360e7ca2780bf4684d916ec13361b5f6fcc SHA512 a0129c49ca574afaefa77c412143571af2eb1100c7d737d497b65d44680d35e2404ee2d4d4e1378b06ac1bcc5c587f505f79fea9251af1cbb36afd990d48570d
+EBUILD libstrophe-0.9.2.ebuild 982 BLAKE2B d5069f4bd65399c4fb4bfeb3a393cdde866bb1220b90bef7e8049a2a18222eba8f5cee1188e2272a3d868adbc73cb9f5ab11e60f275fe89bafeb748403c74df8 SHA512 fa67f32a81ac19b5a00cc51c53eda54851125831206adbbb2ce9ca8a6ee8c92b12afe70b54aad4a4fb444783df00a66c7a65e01fde1a1f510a64bf65651039bb
+MISC metadata.xml 591 BLAKE2B 0706dfaeb6ebcf44525e7ecfe772c8496020da59ed5b3024775e41a79ec0ac5861d118e136d45187f819e70ac7e2bf360bf210d159167aeb1eccaa75747353fd SHA512 d05b0612eae08214749144fdca408ae9b630cd9763762fec74b46639d7faed460c2c4cc07e278453c637376e78aa50eafdf137a6143f7ded355358ffb292fd60
diff --git a/dev-libs/libstrophe/files/libstrophe-0.9.2-libressl.patch b/dev-libs/libstrophe/files/libstrophe-0.9.2-libressl.patch
new file mode 100644
index 000000000000..1c0cf239cdfc
--- /dev/null
+++ b/dev-libs/libstrophe/files/libstrophe-0.9.2-libressl.patch
@@ -0,0 +1,20 @@
+--- a/src/tls_openssl.c
++++ b/src/tls_openssl.c
+@@ -51,7 +51,7 @@
+
+ void tls_initialize(void)
+ {
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL)
+ SSL_library_init();
+ SSL_load_error_strings();
+ #else
+@@ -120,7 +120,7 @@
+ /* Trust server's certificate when user sets the flag explicitly. */
+ mode = conn->tls_trust ? SSL_VERIFY_NONE : SSL_VERIFY_PEER;
+ SSL_set_verify(tls->ssl, mode, 0);
+-#if OPENSSL_VERSION_NUMBER >= 0x10002000L
++#if OPENSSL_VERSION_NUMBER >= 0x10002000L && (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER >= 0x2070000fL)
+ /* Hostname verification is supported in OpenSSL 1.0.2 and newer. */
+ X509_VERIFY_PARAM *param = SSL_get0_param(tls->ssl);
+
diff --git a/dev-libs/libstrophe/libstrophe-0.9.2.ebuild b/dev-libs/libstrophe/libstrophe-0.9.2.ebuild
new file mode 100644
index 000000000000..f95cbfb67f5e
--- /dev/null
+++ b/dev-libs/libstrophe/libstrophe-0.9.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="|| ( MIT GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc expat libressl"
+
+RDEPEND="
+ expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2:2 )
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( ChangeLog )
+PATCHES=( "${FILESDIR}/libstrophe-0.9.2-libressl.patch" )
+
+src_configure() {
+ # shellcheck disable=SC2207
+ local myeconf=(
+ --enable-tls
+ $(use_with !expat libxml2)
+ )
+ econf "${myeconf[@]}"
+}
+src_compile() {
+ default
+ if use doc; then
+ doxygen || die
+ HTML_DOCS=( docs/html/* )
+ fi
+}
+
+src_install() {
+ default
+ use doc && dodoc -r examples
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libstrophe/metadata.xml b/dev-libs/libstrophe/metadata.xml
new file mode 100644
index 000000000000..66bfa18199e7
--- /dev/null
+++ b/dev-libs/libstrophe/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">strophe/libstrophe</remote-id>
+ <bugs-to>https://github.com/strophe/libstrophe/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ libstrophe is a lightweight XMPP client library written
+ in C. It has minimal dependencies and is configurable
+ for various environments.
+ </longdescription>
+</pkgmetadata>