summaryrefslogtreecommitdiff
path: root/dev-libs/libstrophe/libstrophe-0.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 05:24:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 05:24:29 +0100
commit007b0aae027279095b8605c214b535e59df8f6eb (patch)
tree3ab8d7df4662438a0507197b948705b4772083d5 /dev-libs/libstrophe/libstrophe-0.12.2.ebuild
parentf20958f66a5e97c92cc44354e07e3e3089dfc23d (diff)
gentoo auto-resync : 03:05:2023 - 05:24:28
Diffstat (limited to 'dev-libs/libstrophe/libstrophe-0.12.2.ebuild')
-rw-r--r--dev-libs/libstrophe/libstrophe-0.12.2.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-libs/libstrophe/libstrophe-0.12.2.ebuild b/dev-libs/libstrophe/libstrophe-0.12.2.ebuild
index 712039ac8782..1e4a8b48e633 100644
--- a/dev-libs/libstrophe/libstrophe-0.12.2.ebuild
+++ b/dev-libs/libstrophe/libstrophe-0.12.2.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+inherit autotools
+
DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
HOMEPAGE="https://strophe.im/libstrophe/"
# 2nd SRC is a backport of the /bin/sh -> dash fix, #877049, #879533
@@ -34,6 +37,13 @@ PATCHES=(
"${DISTDIR}/${PN}-fix-configure-bashisms.patch"
)
+src_prepare() {
+ default
+
+ # Needed for bashisms patch which touches configure
+ eautoreconf
+}
+
src_configure() {
# shellcheck disable=SC2207
local myeconf=(
@@ -43,6 +53,7 @@ src_configure() {
)
econf "${myeconf[@]}"
}
+
src_compile() {
default
if use doc; then