summaryrefslogtreecommitdiff
path: root/dev-libs/libsqlora8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libsqlora8
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libsqlora8')
-rw-r--r--dev-libs/libsqlora8/Manifest5
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild55
-rw-r--r--dev-libs/libsqlora8/metadata.xml12
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/libsqlora8/Manifest b/dev-libs/libsqlora8/Manifest
new file mode 100644
index 000000000000..81e33a3c01c9
--- /dev/null
+++ b/dev-libs/libsqlora8/Manifest
@@ -0,0 +1,5 @@
+DIST libsqlora8-2.3.3.tar.gz 1130458 SHA256 958f68fa7f7d64de5231333d0eac268bdb936152ba0572d57b3668f62da66bc1 SHA512 5c62387f11cc8b901d99c2981f7e7099d255203aa11a071fc53b22d770db3485f0f23e054b88b3b0f281546a5e92fd5a7bd46b4f0e5f51a8914894c54f222c6e WHIRLPOOL 9ef5fcee46cfcc11f0e08ac6ce83d3f9cfdf6d163c5755753cf04ded9f491cf3c43a7c29c1d9c01d6264d987c1ddae6817104fb7095181517fa459820f8c4e81
+EBUILD libsqlora8-2.3.3-r1.ebuild 1264 SHA256 3d6f5890fd03be6f5b22fc883a28d3b6a14b3e4884e8b63f0903952391eca7e6 SHA512 739b82d31084d43bf053da8dd38958a46479dd6cb764daabc88959022ab5d4887dd069f124c206c654c632d58c34ec328cfd03eecc26a3bc08bdcc2a310392a7 WHIRLPOOL 79b2b92f244ca88047ca26394da24b1484c7bfbcfb62279f3856a961059b195d09242bf7432e6d51d250ab2c006da50089e6cbc42324e7d3f46af7e591488814
+MISC ChangeLog 3434 SHA256 d42e2f1d6506b796609f6e15442bde15a73fdcd63a6e6a719f2cbce39dff90ae SHA512 8c59e9be3b7dd84e6842a7d2d2717c540eea84b30319a6307dd45a5ab0012e146221ab6e432f5bc0bbf8a7f3310892fcf82af23d4203aec72162dc9e0eabc130 WHIRLPOOL 1d309b99a6497b27a7638fccd711960fe47841b7761da3c126585948b7b7da809d32ac4f2c50a68b2305da15ac1973ba1659f53b0d52a90cd3d454f75b0f59a7
+MISC ChangeLog-2015 1676 SHA256 eecab84478082acb9ef957d49a6af842ddc5d9bc64373713c4943fb8ccdb48ed SHA512 b614cb6cf94b44ba25b38fd10320fa3bb293350c57aaa59ed905f63b644d35a0c3ef17d6bcc09406496dbf752cf77baff0f2682bc0b405dd4f301cd71d6a4dab WHIRLPOOL f0245f808f2d75c122c74b54dddd02a6519d94e1ea3037b54d3a9aa098c378ecc20c3a6b9146b5578dbb1130bbe6e8807aaf9575fcf34f70ed6df79d855b96d6
+MISC metadata.xml 417 SHA256 780c847fdc630287a53c2c2b8492ef74699b9e3b6672e561f3589fae8caa0681 SHA512 287a9087ada0f1b1c52601f8f96d326b0e86eadca05d7b05ff0b2a14cd7d62e4a788d48199514a64bd602063068b530b243ee2a696dd205ffd45b44a867d02ee WHIRLPOOL 5881d7d300a90acc82990e2be628c614b3999e5f9cbdbc80065725364e4157be353b4b92974572412180a747381723fb02c7ec49adfcfb40cc5810df223679b5
diff --git a/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..7e8df7fae210
--- /dev/null
+++ b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic versionator
+
+DESCRIPTION="Simple C-library to access Oracle databases via the OCI interface"
+SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
+HOMEPAGE="http://www.poitschke.de/libsqlora8/index_noframe.html"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="orathreads static-libs +threads"
+
+RDEPEND="dev-db/oracle-instantclient"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="?? ( orathreads threads )"
+
+src_configure() {
+ local myconf
+
+ local ORACLE_VER="$(best_version dev-db/oracle-instantclient)"
+ ORACLE_VER="${ORACLE_VER#*/*-*-}" #reduce it to ${PV}-${PR}
+ ORACLE_VER="$(get_version_component_range 1-2 ${ORACLE_VER})"
+ append-ldflags -L"/usr/lib/oracle/${ORACLE_VER}/client/lib"
+
+ use threads && myconf="--with-threads=posix"
+ use orathreads && myconf="--with-threads=oracle"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ # Parallel compilation is not supported
+ emake -j1
+}
+
+src_install () {
+ default
+ prune_libtool_files
+ dodoc ChangeLog NEWS NEWS-2.2
+
+ # TODO
+ # Copy contents of doc and examples directory to proper place
+ rm -r "${D}/usr/share/doc/packages"
+}
diff --git a/dev-libs/libsqlora8/metadata.xml b/dev-libs/libsqlora8/metadata.xml
new file mode 100644
index 000000000000..60a8019dbd9a
--- /dev/null
+++ b/dev-libs/libsqlora8/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription>
+ libsqlora8 is simple C-library to access Oracle databases via the OCI
+ interface. Makes simple programming tasks much easier than with plain OCI.
+</longdescription>
+<use>
+ <flag name="orathreads">Use Oracle threads</flag>
+</use>
+</pkgmetadata>