summaryrefslogtreecommitdiff
path: root/dev-libs/libsecp256k1/libsecp256k1-0.0.0_pre20151118.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libsecp256k1/libsecp256k1-0.0.0_pre20151118.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libsecp256k1/libsecp256k1-0.0.0_pre20151118.ebuild')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-0.0.0_pre20151118.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-0.0.0_pre20151118.ebuild b/dev-libs/libsecp256k1/libsecp256k1-0.0.0_pre20151118.ebuild
new file mode 100644
index 000000000000..4609c06bb272
--- /dev/null
+++ b/dev-libs/libsecp256k1/libsecp256k1-0.0.0_pre20151118.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+MyPN=secp256k1
+DESCRIPTION="Optimized C library for EC operations on curve secp256k1"
+HOMEPAGE="https://github.com/bitcoin/${MyPN}"
+COMMITHASH="6c527eceee7f5105c33c98dfae24ffeffd71f7cf"
+SRC_URI="https://github.com/bitcoin/${MyPN}/archive/${COMMITHASH}.tar.gz -> ${MyPN}-v${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~mips ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE="+asm doc ecdh endomorphism experimental gmp libressl +recovery schnorr test"
+
+REQUIRED_USE="
+ asm? ( amd64 )
+ ecdh? ( experimental )
+ schnorr? ( experimental )
+"
+RDEPEND="
+ gmp? ( dev-libs/gmp:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+
+S="${WORKDIR}/${MyPN}-${COMMITHASH}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-benchmark \
+ $(use_enable test tests) \
+ $(use_enable ecdh module-ecdh) \
+ $(use_enable endomorphism) \
+ --with-asm=$(usex asm auto no) \
+ --with-bignum=$(usex gmp gmp no) \
+ $(use_enable recovery module-recovery) \
+ $(use_enable schnorr module-schnorr) \
+ --disable-static
+}
+
+src_install() {
+ if use doc; then
+ dodoc README.md
+ fi
+
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+}