summaryrefslogtreecommitdiff
path: root/dev-libs/libreport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-libs/libreport
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-libs/libreport')
-rw-r--r--dev-libs/libreport/Manifest2
-rw-r--r--dev-libs/libreport/libreport-2.16.0.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index 80782c45efd5..3856fbfa8825 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1,3 +1,5 @@
DIST libreport-2.15.2.tar.gz 1859867 BLAKE2B f890e3cb8b2a23647e4c3fb0caaf984b1b21fd32e066d04f835f8a475e317cbc75287375e0a10a01b91670d04bba1f15b1180065f7029b8d7d1c0a2fb890914b SHA512 c98003325fa70d674177c9f602a7f121815a9675701ee780ad8908ed69862f2c69be65c7483fd3f017ba299dda51ba304f0908c771c9d97cb5bba057e3a9c5dc
+DIST libreport-2.16.0.tar.gz 1901880 BLAKE2B 520ad157de02dbe5fd15b2ffcfc9b0a09587c3696b41a202f0a78b53a2d366a2991906437aa38d7c84407dcd4a788d358b9e320f70c30e602f1b903433288717 SHA512 cbb456bb63b92a255fecb87191160c2e515b4434cbaaa9404fb69f4f78421fe98c4057969f4b6b99e1b52e815d83c483bdbbe606a4bd2e34cf5268769e7bd40f
EBUILD libreport-2.15.2.ebuild 1942 BLAKE2B fffb0d535a1c653c12ef66c4c216276dd5cbcec78f83f9f7a947d0aa645503c05b52be1b2fd1be1c181909adaf2fde992df058898d83c37edd19f68252e3eae7 SHA512 bb7477486d972a73b543444925290dea0eb5b68f1e14db85e6f7a653d5c5bc9f2c049451c3ab346712ff380d1beb936bc56a6bca302c9bf39a547aee8d44632c
+EBUILD libreport-2.16.0.ebuild 1949 BLAKE2B 7b103e6feec98f7bc70478fc06f6865397c7cbeea7d2022002ef2dcc4332c996b648ca3a720af58c7d410470535331aea61146d66aa418360c1a00c73a66e9b4 SHA512 b6ba7594be9f8adc9c659ec4409f1c20716a964526d38c3aa0da99f5310b4fca9aa69e1c5b8f30081d21f1d8e130cb009b78f8f5e72813a45ffe22369a088237
MISC metadata.xml 240 BLAKE2B 1f4d972fe6e8f4096f8905fe5ec3f77b8689f3b0e01ac676ae4e55ce3aa66c18473cc82b5766131f155b9f4cd3fa6c541ab3bd32bfd233ff89722937105f968a SHA512 2e9f28bd0e525aa062cb098048dd176668b1ca2220e0018279ec4779eb80a2e8ad4f1ea73899aded97b7d27379e88d2f60cc80af4a6992880edf6e301b7e1090
diff --git a/dev-libs/libreport/libreport-2.16.0.ebuild b/dev-libs/libreport/libreport-2.16.0.ebuild
new file mode 100644
index 000000000000..f8d64e4b1687
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.16.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk +python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ app-arch/libarchive:0=
+ >=dev-libs/glib-2.43.4:2
+ >=dev-libs/satyr-0.38:0=
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/nettle:=
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ $(use_with gtk)
+ $(use_with python python3)
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}