summaryrefslogtreecommitdiff
path: root/dev-libs/libreport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /dev-libs/libreport
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'dev-libs/libreport')
-rw-r--r--dev-libs/libreport/Manifest2
-rw-r--r--dev-libs/libreport/libreport-2.9.5.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index 772e39a6c3de..d17a5d32d318 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -4,5 +4,7 @@ AUX libreport-2.0.13-json-c-0.11-pc.patch 1780 BLAKE2B bce31a7535097d11d26a36afb
AUX libreport-2.0.13-json-c-0.11.patch 1145 BLAKE2B 2e4bd653b4c378875ffe846f8cfb84f6feabb9e571079fee873c064a092a97a89b4cc7a82e53c57a34a8a9b7510ddac24f907f4dc92cbc3cb6563247dbbad46a SHA512 fd07c360d599d71fddb6766860203052fb390cde6cb795779e75a2d2a826affd6f03c6977eb99237caffdc41ac9f0e1c600a9414f72629ff5fc2102c70d8ca67
AUX libreport-2.0.7-uploader_event-syntax.patch 610 BLAKE2B 5bdd1835310125c3adddef9e338928505e204668ef5448d4991fb67cb9742740dd802caf67d3be3616bcc17c1022f48a4f3d1db9989e171ba30054985b53d0a6 SHA512 b0ae2617a013fd8cb3475e5a51073677f2ea965a57169c760e542474351293e70f70e678a66beeb3b3fa163589aaf7f79f0883fa55ff524e62b5fcd3ae919bf0
DIST libreport-2.0.13.tar.gz 1190147 BLAKE2B fe79d924fbf7bd11cc3fd23956a137fb296baf9c40f12f3ecfefe68c82281f62299887511a096196b4fdcdc9245ab268592dace4e728c2c34af47581e52f5132 SHA512 cfe963db8091b245f8ceb7d8501466f4f9464c28d298faeafc9f6e57deafdfdc6501d468bf5ffd83703adb67bc1e05e06c56b5c0e0028bb2e0134788ddbb2181
+DIST libreport-2.9.5.tar.gz 2271742 BLAKE2B e74d694c0012e984aab8044e99fee8e12a197c0a2edb933e78f045260043d40557509056b1093bc13cbe983976d5525cde1f7596a942760df10c857e99d6b56e SHA512 f207710d88f39870d08e3a5fdfa3e1d5a808625bd36b1dcce363cefd39e582bad6be6dc4224db5e1df4404734c3dd69c437c377303fe978ae21b608fceb833ce
EBUILD libreport-2.0.13-r1.ebuild 2141 BLAKE2B b49f76f03adeaefd952003d1e7bb561b10d7af1b7b399748f0209cd33ea9a40f49e3861e95500a781eaa940735b6d387cb6d168411672d234173e15edd4b8979 SHA512 c0666dd82fcec73ef563886376a6d1449e505239308417e8145e2ce5b394dcc9b4811e9cc3f166a61898b6c7877831b66a1c0d8ef8c76d39e4b5024a54ac4ce7
+EBUILD libreport-2.9.5.ebuild 1942 BLAKE2B 77208961ecd909a18a95cec2ab1ae5468370a93397083b9bb15bde1637b0855eade8a27219f277f0683a7560258a0ad46580925b4b4c2fd7c06ad87e16fb6542 SHA512 fea36a756e7e50ae20aa67f9c8a9a168f3bd15779f663a08b9cd04852fd9fe4ad626117223bfa0156f7aa4961235c27ac5c6ba64f868c80c97afb9fc92841b15
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/libreport/libreport-2.9.5.ebuild b/dev-libs/libreport/libreport-2.9.5.ebuild
new file mode 100644
index 000000000000..9d1da641fb02
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.9.5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools python-r1 user
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+gtk python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ >=dev-libs/glib-2.43:2
+ dev-libs/satyr
+ dev-libs/json-c:=
+ dev-libs/libtar
+ dev-libs/libxml2:2
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup abrt
+ enewuser abrt -1 -1 -1 abrt
+}
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ # Fixes "syntax error in VERSION script" and we aren't supporting Python2 anyway
+ --without-python2
+ $(usex python "--with-python3" "--without-python3")
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir \
+ econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ use python && python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ use python && python_foreach_impl run_in_build_dir default
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}