summaryrefslogtreecommitdiff
path: root/dev-libs/libreport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-libs/libreport
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-libs/libreport')
-rw-r--r--dev-libs/libreport/Manifest2
-rw-r--r--dev-libs/libreport/libreport-2.15.1.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-libs/libreport/Manifest b/dev-libs/libreport/Manifest
index f3b6da383ea0..e512552cd976 100644
--- a/dev-libs/libreport/Manifest
+++ b/dev-libs/libreport/Manifest
@@ -1,5 +1,7 @@
DIST libreport-2.13.1.tar.gz 1841698 BLAKE2B e0fbebbb557fb9fb320dea0a8face6a2eabdb0ad80b5de092e5e4dfe2a0439a4804d4ec99c1286aaafa31064496a94fabce5e26f851001eb9c3bb9989a46e4bb SHA512 6c2ea47e6efa36f23030fbe08946d1e524690e5f6279cbfdaf7c463ef71b23ae82a5e4471ddce89b35d4024f58197cef9f58a07dfcf5bbc1a9b310e39966f81a
DIST libreport-2.15.0.tar.gz 1859305 BLAKE2B ceedd392bd0c7fc5c3f0db5d4a63ced6a1e430b09d1d085996ce735daef5f48cd18267fb1401d9343857619daef6f7f3dcea8508c62313a9f908e5573508649c SHA512 7baaa1fb65face910e55ad06e53af08c5e31f058bf5936c3c1d45581e050380b5db75659b5a493cc626a81795d82616a2dfad696d60c107929cfb8e2905e7f4c
+DIST libreport-2.15.1.tar.gz 1860410 BLAKE2B 43743fc7a7698851e247956621286cc94dbfcc451b8d95aaff9263e65f787b23f7bbf5d7ec087196d5f9f30a697c66e547bbccdc913b3ea2a17ea4c7bf77ee02 SHA512 70f947690173a0afa57981c9755a18bdd0ad44c888c00713de74624296b81ff25203d5dda5d5c57eac85da4a1631585184b77715c7adf6688b469e32d4113cf4
EBUILD libreport-2.13.1.ebuild 1932 BLAKE2B b1b0ac62d7a18a8574de59aefabc42b709e0383f709ffc3a0d237c55c7b85fbede70845062a4e5e3597de5a6628a5167765eed6df8086d87c49067b8fdfdba28 SHA512 df3cc87bb015cad4a3e806d6aa91b2c6894fa40006c6122c973e97467e00c689e8d7dfdd5d9aff152fdb46af6beafd83ef555d656c2eb0c7a6793b0ce87054da
EBUILD libreport-2.15.0.ebuild 1939 BLAKE2B a8396e59929c8fe1c3202a9cbde980dbcead4c5e44c717371fc6ef9f023bc0eb4bfa3ccdebb6a1a71c213f12ad03c8a66e05da00998a10b7aab731c5b5dd8aee SHA512 c069c3d1184617bbb14cc579f5ab78ff13d4d5e6527bab2b81a4b1922ff917de64ca5f167221cdcb7b0365a71ce50c1844f93642ddf55ce36b2d50b3e28e8988
+EBUILD libreport-2.15.1.ebuild 1941 BLAKE2B 999dd154bf0da4387db110706c4a9139fc905a1ec59b7c6b3a0567099626b8f7a175e033d9398fe0e45b4e824e3675bb9526c44ca3d818af08b89f79935ad356 SHA512 ad0a31390264afb01e74acd8d31cf9002785f5210674aac5cae05012b12458dbc1bb7a8036d7f064dbd77d3523b7880f59b7858cdf7911f496b6cfca8dcfbd45
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-libs/libreport/libreport-2.15.1.ebuild b/dev-libs/libreport/libreport-2.15.1.ebuild
new file mode 100644
index 000000000000..2cdc5d5a57d5
--- /dev/null
+++ b/dev-libs/libreport/libreport-2.15.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Generic library for reporting software bugs"
+HOMEPAGE="https://github.com/abrt/libreport"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk +python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-admin/augeas
+ app-arch/libarchive:0=
+ >=dev-libs/glib-2.43.4:2
+ dev-libs/satyr:0=
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/nettle:=
+ dev-libs/newt:=
+ dev-libs/xmlrpc-c:=
+ net-libs/libproxy:=
+ net-misc/curl:=[ssl]
+ sys-apps/dbus
+ sys-apps/systemd
+ gtk? ( >=x11-libs/gtk+-3.3.12:3 )
+ python? ( ${PYTHON_DEPS} )
+ x11-misc/xdg-utils
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+"
+BDEPEND="
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.3.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+# Tests require python-meh, which is highly redhat-specific.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-bugzilla
+ $(use_with gtk)
+ $(use_with python python3)
+ )
+ if use python; then
+ python_foreach_impl run_in_build_dir econf "${myargs[@]}"
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ # Need to set correct ownership for use by app-admin/abrt
+ diropts -o abrt -g abrt
+ keepdir /var/spool/abrt
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}