summaryrefslogtreecommitdiff
path: root/dev-libs/librep/librep-0.92.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-libs/librep/librep-0.92.6.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-libs/librep/librep-0.92.6.ebuild')
-rw-r--r--dev-libs/librep/librep-0.92.6.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/dev-libs/librep/librep-0.92.6.ebuild b/dev-libs/librep/librep-0.92.6.ebuild
deleted file mode 100644
index 0028c09381f7..000000000000
--- a/dev-libs/librep/librep-0.92.6.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools elisp-common eutils flag-o-matic ltprune
-
-DESCRIPTION="Shared library implementing a Lisp dialect"
-HOMEPAGE="http://librep.sourceforge.net/"
-SRC_URI="http://download.tuxfamily.org/librep/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="emacs readline"
-
-RDEPEND="
- >=sys-libs/gdbm-1.8.0
- emacs? ( >=app-editors/emacs-23.1:* )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}
- sys-apps/texinfo
- app-arch/xz-utils
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.92.0-disable-elisp.patch"
-)
-
-S="${WORKDIR}/${PN}_${PV}"
-
-src_prepare() {
- # fix #570072 by restoring pre-GCC5 inline semantics
- append-cflags -std=gnu89
- default
-
- # The configure script is missing from this version.
- eautoreconf
-}
-
-src_configure() {
- econf \
- --libexecdir=/usr/$(get_libdir) \
- --without-gmp \
- --without-ffi \
- --disable-static \
- $(use_with readline)
-}
-
-src_compile() {
- default
-
- if use emacs; then
- elisp-compile rep-debugger.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- default
- prune_libtool_files --modules
-
- dodoc doc/*
-
- if use emacs; then
- elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" \
- || die "elisp-site-file-install failed"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}