summaryrefslogtreecommitdiff
path: root/dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
commit30c53e395853f5bfe805a1e429fcf26666eed8f8 (patch)
treea0670eaf9babda7b83503f7d36806a944bb49752 /dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch
parentd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (diff)
gentoo resync : 17.05.2018
Diffstat (limited to 'dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch')
-rw-r--r--dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch b/dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch
new file mode 100644
index 000000000000..15f605dd4825
--- /dev/null
+++ b/dev-libs/librelp/files/librelp-1.2.16-fix-valgrind-usage.patch
@@ -0,0 +1,27 @@
+Upstream bug: https://github.com/rsyslog/librelp/issues/100
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -176,16 +176,20 @@ fi
+
+ # valgrind
+ AC_ARG_ENABLE(valgrind,
+- [AS_HELP_STRING([--enable-valgrind],[Enable valgrind tests@<:@default=yes@:>@])],
++ [AS_HELP_STRING([--enable-valgrind],[Enable valgrind tests@<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_valgrind="yes" ;;
+ no) enable_valgrind="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-valgrind) ;;
+ esac],
+- [enable_valgrind="yes"]
++ [enable_valgrind="no"]
+ )
+ if test "$enable_valgrind" = "yes"; then
+ AC_CHECK_PROG(VALGRIND, [valgrind], [valgrind], [no])
++
++ if test "x$VALGRIND" = "xno"; then
++ AC_MSG_ERROR([valgrind is missing but forced with --enable-valgrind. Either install valgrind or remove the option!])
++ fi
+ fi
+ AM_CONDITIONAL([HAVE_VALGRIND], test "$enable_valgrind" == "yes")
+