summaryrefslogtreecommitdiff
path: root/dev-libs/libratbag/libratbag-0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libratbag/libratbag-0.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libratbag/libratbag-0.9.ebuild')
-rw-r--r--dev-libs/libratbag/libratbag-0.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libratbag/libratbag-0.9.ebuild b/dev-libs/libratbag/libratbag-0.9.ebuild
new file mode 100644
index 000000000000..0430e0fe0a14
--- /dev/null
+++ b/dev-libs/libratbag/libratbag-0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson udev
+
+DESCRIPTION="Library to configure gaming mice"
+HOMEPAGE="https://github.com/libratbag/libratbag"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/libevdev
+ virtual/libudev
+"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-documentation=$(usex doc true false)
+ -Denable-tests=$(usex test true false)
+ -Dudev-dir=$(get_udevdir)
+ )
+ meson_src_configure
+}