summaryrefslogtreecommitdiff
path: root/dev-libs/libpy/libpy-0.2.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
commitb987a550f067c3da93b0664cf1fdc8a624c0aa38 (patch)
tree9ad1767fad656d26471a81af6bac8400a1c75218 /dev-libs/libpy/libpy-0.2.5-r2.ebuild
parente3f21c8aff8a76afe3423721c437a088e9232840 (diff)
gentoo auto-resync : 24:04:2024 - 23:59:27
Diffstat (limited to 'dev-libs/libpy/libpy-0.2.5-r2.ebuild')
-rw-r--r--dev-libs/libpy/libpy-0.2.5-r2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-libs/libpy/libpy-0.2.5-r2.ebuild b/dev-libs/libpy/libpy-0.2.5-r2.ebuild
deleted file mode 100644
index e11055754550..000000000000
--- a/dev-libs/libpy/libpy-0.2.5-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-inherit flag-o-matic distutils-r1
-
-GTEST_VER="23b2a3b1cf803999fb38175f6e9e038a4495c8a5"
-
-DESCRIPTION="Utilities for writing C++ extension modules"
-HOMEPAGE="https://quantopian.github.io/libpy/
- https://github.com/quantopian/libpy"
-SRC_URI="
- https://github.com/quantopian/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/google/googletest/archive/${GTEST_VER}.tar.gz -> gtest-${GTEST_VER}.tar.gz )
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="sparsehash test"
-
-COMMON_DEPEND="
- >=dev-python/numpy-1.11.3[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${COMMON_DEPEND}
-"
-BDEPEND="
- ${COMMON_DEPEND}
- sparsehash? ( dev-cpp/sparsehash )
- test? (
- dev-cpp/gtest
- >=dev-python/pytest-4.4.1[${PYTHON_USEDEP}]
- )
-"
-
-RESTRICT="!test? ( test )"
-REQUIRED_USE="test? ( sparsehash )"
-
-# my C++ isn't good enough to fix the tests
-RESTRICT+=" test"
-
-PATCHES=(
- "${FILESDIR}/libpy-0.2.5-no-werror.patch"
- "${FILESDIR}/libpy-0.2.5-permissions.patch"
- "${FILESDIR}/libpy-0.2.5-cflags.patch"
- "${FILESDIR}/libpy-0.2.5-stdint.patch"
- "${FILESDIR}/libpy-0.2.5-setuptools.patch"
-)
-
-python_test() {
- emake GTEST_ROOT="${WORKDIR}/googletest-${GTEST_VER}" test
-}
-
-python_configure() {
- replace-flags '-O*' '-O3'
-}