summaryrefslogtreecommitdiff
path: root/dev-libs/libpfm/libpfm-4.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
commitd37f8725bb68034ef10d8882fb4411a49f2f666e (patch)
tree2b530ee04815bacc1dc051db24c2727d3056b77b /dev-libs/libpfm/libpfm-4.12.0.ebuild
parent171d09fa1f429aa43835c618a2c21753ad5209a4 (diff)
gentoo auto-resync : 21:02:2023 - 20:25:12
Diffstat (limited to 'dev-libs/libpfm/libpfm-4.12.0.ebuild')
-rw-r--r--dev-libs/libpfm/libpfm-4.12.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libpfm/libpfm-4.12.0.ebuild b/dev-libs/libpfm/libpfm-4.12.0.ebuild
new file mode 100644
index 000000000000..78e428370b01
--- /dev/null
+++ b/dev-libs/libpfm/libpfm-4.12.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hardware-based performance monitoring interface for Linux"
+HOMEPAGE="http://perfmon2.sourceforge.net"
+SRC_URI="mirror://sourceforge/perfmon2/${PN}4/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0/4"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+
+ sed -e "s:SLDFLAGS=:SLDFLAGS=\$(LDFLAGS) :g" \
+ -i lib/Makefile || die
+ sed -e "s:LIBDIR=\$(PREFIX)/lib:LIBDIR=\$(PREFIX)/$(get_libdir):g" \
+ -i config.mk || die
+}
+
+src_compile() {
+ # 'DBG=' unsets '-Werror' and other optional flags, bug #664294
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" DBG=
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=true PREFIX="${EPREFIX}/usr" install
+ dodoc README
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}