summaryrefslogtreecommitdiff
path: root/dev-libs/libpeas/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-libs/libpeas/files
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-libs/libpeas/files')
-rw-r--r--dev-libs/libpeas/files/libpeas-1.28.0-tests-Explicitly-depend-on-the-GIR-and-typelib.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libpeas/files/libpeas-1.28.0-tests-Explicitly-depend-on-the-GIR-and-typelib.patch b/dev-libs/libpeas/files/libpeas-1.28.0-tests-Explicitly-depend-on-the-GIR-and-typelib.patch
new file mode 100644
index 000000000000..55a425c9d513
--- /dev/null
+++ b/dev-libs/libpeas/files/libpeas-1.28.0-tests-Explicitly-depend-on-the-GIR-and-typelib.patch
@@ -0,0 +1,41 @@
+From 6d053ec0a4108be59f5e30a04ab4e6539e694e53 Mon Sep 17 00:00:00 2001
+From: Simon McVittie <smcv@debian.org>
+Date: Fri, 18 Sep 2020 11:31:52 +0100
+Subject: [PATCH] tests: Explicitly depend on the GIR and typelib
+
+In Meson since 0.55.0, having the test executable depend on the GIR
+dependency is not enough to ensure that uninstalled GIR and typelib
+files are generated: we also need to have the test itself depend on
+the GIR build target.
+
+It is not clear to me whether this is a workaround for a Meson
+regression (if what libpeas previously did was meant to work), or a
+solution to a libpeas bug (if it was never meant to be guaranteed to
+work). For more details see
+<https://github.com/mesonbuild/meson/issues/7756>.
+
+Resolves: https://gitlab.gnome.org/GNOME/libpeas/-/issues/40
+Bug-Debian: https://bugs.debian.org/966951
+---
+ tests/libpeas/meson.build | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/tests/libpeas/meson.build b/tests/libpeas/meson.build
+index 32cf5e9..c95190a 100644
+--- a/tests/libpeas/meson.build
++++ b/tests/libpeas/meson.build
+@@ -53,5 +53,10 @@ foreach test: libpeas_tests_sources
+ c_args: libpeas_tests_c_args,
+ )
+
+- test('test-@0@'.format(test_name), test_exe, env: test_env)
++ test(
++ 'test-@0@'.format(test_name),
++ test_exe,
++ depends: [libintrospection_gir],
++ env: test_env,
++ )
+ endforeach
+--
+2.26.2
+