summaryrefslogtreecommitdiff
path: root/dev-libs/liborcus/liborcus-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-27 06:56:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-27 06:56:55 +0000
commit9c4ecbcb1ba97e8bfd6dac8c2433fb9fdfee5fe6 (patch)
tree464689c17706867ab99f0e14017c82d3b3c98a11 /dev-libs/liborcus/liborcus-9999.ebuild
parented0a1596c807e379a19960170c94735aff22fa84 (diff)
gentoo auto-resync : 27:01:2024 - 06:56:55
Diffstat (limited to 'dev-libs/liborcus/liborcus-9999.ebuild')
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index 53b0600bb160..2e109680a08b 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit autotools python-single-r1
DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/2.1"
+ MDDS_SLOT="1/3.0"
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
inherit git-r3
else
- MDDS_SLOT="1/2.0"
+ MDDS_SLOT="1/2.1"
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
-SLOT="0/0.18" # based on SONAME of liborcus.so
+SLOT="0/0.20" # based on SONAME of liborcus.so
IUSE="python +spreadsheet-model test tools"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -41,15 +41,13 @@ pkg_setup() {
}
src_prepare() {
- # bug 713586
- use test && eapply "${FILESDIR}/${P}-test-fix.patch"
-
default
eautoreconf
}
src_configure() {
local myeconfargs=(
+ --without-benchmark
--disable-werror
$(use_enable python)
$(use_enable spreadsheet-model)
@@ -60,5 +58,6 @@ src_configure() {
src_install() {
default
+ python_optimize
find "${D}" -name '*.la' -type f -delete || die
}