summaryrefslogtreecommitdiff
path: root/dev-libs/libofx/libofx-0.9.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libofx/libofx-0.9.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libofx/libofx-0.9.10.ebuild')
-rw-r--r--dev-libs/libofx/libofx-0.9.10.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libofx/libofx-0.9.10.ebuild b/dev-libs/libofx/libofx-0.9.10.ebuild
new file mode 100644
index 000000000000..af1022953385
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.9.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A library to support the Open Financial eXchange XML format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc ~ppc64 x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ >=app-text/opensp-1.5
+ dev-cpp/libxmlpp:2.6
+ >=net-misc/curl-7.9.7
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig
+ test? ( app-crypt/gnupg )
+"
+
+src_prepare() {
+ autotools-utils_src_prepare
+
+ # Be sure DTD gets installed in correct path after redefining docdir in install
+ sed -i \
+ -e 's:$(DESTDIR)$(docdir):$(DESTDIR)$(LIBOFX_DTD_DIR):' \
+ dtd/Makefile.in || die
+
+ # configure arguments alone don't disable everything
+ sed -e "/^SUBDIRS/s/doc//" -i Makefile.in || die
+}
+
+src_compile() {
+ autotools-utils_src_compile CXXFLAGS+=-std=c++11 #566456
+}
+
+src_install() {
+ autotools-utils_src_install docdir="/usr/share/doc/${PF}"
+
+ rm -f "${ED}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+}