summaryrefslogtreecommitdiff
path: root/dev-libs/libnsfb/libnsfb-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-libs/libnsfb/libnsfb-0.2.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-libs/libnsfb/libnsfb-0.2.1.ebuild')
-rw-r--r--dev-libs/libnsfb/libnsfb-0.2.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libnsfb/libnsfb-0.2.1.ebuild b/dev-libs/libnsfb/libnsfb-0.2.1.ebuild
new file mode 100644
index 000000000000..9c7ec5bfe438
--- /dev/null
+++ b/dev-libs/libnsfb/libnsfb-0.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="framebuffer abstraction library, written in C"
+HOMEPAGE="http://www.netsurf-browser.org/projects/libnsfb/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE="sdl test vnc wayland xcb"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sdl? ( >=media-libs/libsdl-1.2.15-r4 )
+ vnc? ( >=net-libs/libvncserver-0.9.9-r2 )
+ wayland? ( >=dev-libs/wayland-1.0.6 )
+ xcb? (
+ >=x11-libs/libxcb-1.9.1
+ >=x11-libs/xcb-util-0.3.9-r1
+ >=x11-libs/xcb-util-image-0.3.9-r1
+ >=x11-libs/xcb-util-keysyms-0.3.9-r1
+ )"
+BDEPEND="
+ dev-util/netsurf-buildsystem"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.1.0-autodetect.patch )
+
+DOCS=( usage )
+
+_emake() {
+ source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+ netsurf_define_makeconf
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared \
+ WITH_VNC=$(usex vnc) \
+ WITH_SDL=$(usex sdl) \
+ WITH_XCB=$(usex xcb) \
+ WITH_WLD=$(usex wayland) \
+ $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install
+}