summaryrefslogtreecommitdiff
path: root/dev-libs/libnl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-libs/libnl
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/Manifest2
-rw-r--r--dev-libs/libnl/libnl-99999999.ebuild10
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/libnl/Manifest b/dev-libs/libnl/Manifest
index 6e708ec773f5..0a00becf95af 100644
--- a/dev-libs/libnl/Manifest
+++ b/dev-libs/libnl/Manifest
@@ -8,5 +8,5 @@ EBUILD libnl-1.1.4-r1.ebuild 1165 BLAKE2B c53d5fc1b86e016bf89cf590a9bb8f65f9abc4
EBUILD libnl-1.1.4.ebuild 1141 BLAKE2B 16521e18a8b986a96540245ed54c5737c1ba8d17d3a492fe34b2e504216ba21186d1eaf4685716894f826186a87dd3b4ad82c87d9a4e439cd984fdf0472b4828 SHA512 1c63d4eabb1268b349918acbdc3cbc7d2fabc09a75e4b07793f1e380309404f460bfc3b90c7426377d57be65f5b679a5d20155003ab589497b225dea2f9c281a
EBUILD libnl-3.4.0.ebuild 2407 BLAKE2B 7bb952c54ccaa828e964afae46e02aeafaaef93eb357c09b70f5c56966a11d261f40a402f41668adcd781d5b006e2d971b2325aff594024e71da6d9dacd92677 SHA512 a2a65e942a7f2dd0209a2afae4964af96d0133fe73cb76b8cbc9131e9b8b246b74f05a1869a10c25f0ce539bc7c7bae4bca7ff6639ade62a031245356a1db05c
EBUILD libnl-3.5.0.ebuild 2412 BLAKE2B 823b9e509a918f65e677233921127990c063e97fd6c8c302e924917428913c2da2de4649daef6a88ebd4d6e3acf3b0c49d905e239f8b5a259d6c07275222ee41 SHA512 b008bbe84e8f5e90f9de71442d8da8998448bdbee8e726f4b9d57e9e5720b35c934da55dfe25748bf39837cce03cd6d23cf26038cb3c4ac111543028019c0cd9
-EBUILD libnl-99999999.ebuild 2191 BLAKE2B c809f82bfa87fb44a6e0447f7f92e9f046027c45ea7780ce0d1c59261f302ad88d83ed4c474e7fde04696ad93b535eeb63f8a794ef5772dd837ee8c478d35a71 SHA512 5714afc5b9651f7de94b9c44723d05c278280b503c7b329ab12c947495ecab7479e34b3e93a001846dd05b3bc89312e5d2b6f69a07697ada101fd5dfd1367920
+EBUILD libnl-99999999.ebuild 2175 BLAKE2B 68c392e976282c0b90ff94d94e7fdfe114f27e5a7f9edb3b799a3963fd3cc4e2e20cfa87ec9bf594dc2ea6e2c6bfa1d5106b361aa2f645eb6b25a5337a05e746 SHA512 ae82c5142e5340ebc5d0f86e959bddc7d22bf953b0134c6c43adfece73b39336106449dd425b2aabe2763b91b9dd2465236044b0d5cea8b1dbce4e1ed487ab3e
MISC metadata.xml 584 BLAKE2B a20cc961918ee8685889b73f8fcdf5cd26a5b0da2ddb95164774461c2fd78754262619d7de2dcb6030f7ef3d27a34057662b2c01cde1fe3729ba1c34bd2a087f SHA512 0e8731a9aafb77b313583babfb2786c4fcbe655f3fcebe93fee90b2ea4c7f03a6ed559a253cb63f5f3a5eb9fd841babcbb5c85c4c93e51a670abe605e9d22a9c
diff --git a/dev-libs/libnl/libnl-99999999.ebuild b/dev-libs/libnl/libnl-99999999.ebuild
index 43eb90b83be5..bb976be45138 100644
--- a/dev-libs/libnl/libnl-99999999.ebuild
+++ b/dev-libs/libnl/libnl-99999999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 eutils git-r3 libtool multilib multilib-minimal
+inherit autotools distutils-r1 git-r3 libtool multilib multilib-minimal
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
@@ -84,7 +84,7 @@ multilib_src_compile() {
}
multilib_src_install() {
- emake DESTDIR="${D}" install
+ default
if multilib_is_native_abi && use python; then
# Unset DOCS= since distutils-r1.eclass interferes
@@ -96,5 +96,5 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
- prune_libtool_files --modules
+ find "${D}" -name '*.la' -delete || die
}