summaryrefslogtreecommitdiff
path: root/dev-libs/libnl/libnl-3.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-libs/libnl/libnl-3.5.0.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-libs/libnl/libnl-3.5.0.ebuild')
-rw-r--r--dev-libs/libnl/libnl-3.5.0.ebuild29
1 files changed, 10 insertions, 19 deletions
diff --git a/dev-libs/libnl/libnl-3.5.0.ebuild b/dev-libs/libnl/libnl-3.5.0.ebuild
index b59acf1f18f4..e94fa798a8f1 100644
--- a/dev-libs/libnl/libnl-3.5.0.ebuild
+++ b/dev-libs/libnl/libnl-3.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_OPTIONAL=1
inherit distutils-r1 libtool multilib-minimal
@@ -13,34 +13,25 @@ LIBNL_DIR=${LIBNL_DIR//./_}
DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
-SRC_URI="
- https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz
-"
+SRC_URI="https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz"
+S="${WORKDIR}/${LIBNL_P}"
+
LICENSE="LGPL-2.1 utils? ( GPL-2 )"
SLOT="3"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="+debug static-libs python +threads utils"
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="
- ${RDEPEND}
-"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
BDEPEND="
${RDEPEND}
python? ( dev-lang/swig )
sys-devel/bison
sys-devel/flex
"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-DOCS=(
- ChangeLog
-)
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-S=${WORKDIR}/${LIBNL_P}
+DOCS=( ChangeLog )
MULTILIB_WRAPPED_HEADERS=(
# we do not install CLI stuff for non-native
@@ -103,5 +94,5 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}