summaryrefslogtreecommitdiff
path: root/dev-libs/libnatspec/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/libnatspec/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/libnatspec/files')
-rw-r--r--dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch20
-rw-r--r--dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch29
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch b/dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch
new file mode 100644
index 000000000000..cf775e7c644e
--- /dev/null
+++ b/dev-libs/libnatspec/files/libnatspec-0.3.0-bashisms.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,7 +33,7 @@
+ dnl Checks for libraries.
+ check_popt=""
+ AC_CHECK_LIB([popt], [main], check_popt=true)
+-if test "x$check_popt" == x ; then
++if test "x$check_popt" = x ; then
+ AC_MSG_WARN([ libpopt not found.])
+ else
+ POPT_LIBS=-lpopt
+@@ -47,7 +47,7 @@
+
+ check_iconv=""
+ AC_CHECK_HEADERS([iconv.h],check_iconv=true)
+-if test "x$check_iconv" == x ; then
++if test "x$check_iconv" = x ; then
+ AC_MSG_ERROR([*** iconv.h not found.])
+ fi
+ AC_CHECK_LIB([iconv], libiconv_open)
diff --git a/dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch b/dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch
new file mode 100644
index 000000000000..cb7c542088ed
--- /dev/null
+++ b/dev-libs/libnatspec/files/libnatspec-0.3.0-doxygen.patch
@@ -0,0 +1,29 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -54,13 +54,10 @@
+
+ # check Doxygen
+ DOXYGEN=""
+-AC_ARG_WITH(doxygen, [ --with-doxygen Generate doxygen documentation ],
+-[AC_CHECK_PROG(DOX, doxygen, yes)
+-if test "x$DOX" != x ; then
+- DOXYGEN="doxygen"
+-else
+- AC_MSG_ERROR([*** Doxygen not found])
+-fi
++AC_ARG_WITH(doxygen, [ --with-doxygen Generate doxygen documentation ])
++AS_IF([test "x$with_doxygen" = "xyes"], [
++ AC_CHECK_PROG(DOX, doxygen, yes)
++ DOXYGEN="doxygen"
+ ])
+ AC_SUBST(DOXYGEN)
+ AM_CONDITIONAL(HAVE_DOXYGEN, test x$DOXYGEN != x)
+--- a/docs/Makefile.am
++++ b/docs/Makefile.am
+@@ -19,5 +19,4 @@
+
+
+ # install
+-docdir = $(datadir)/doc/@PACKAGE@-@VERSION@/html
+-doc_DATA = $(shell find $(top_srcdir)/docs/html -name \*.*)
++html_DATA = $(shell find $(top_srcdir)/docs/html -name \*.*)