summaryrefslogtreecommitdiff
path: root/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libmoe/libmoe-1.5.8-r3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libmoe/libmoe-1.5.8-r3.ebuild')
-rw-r--r--dev-libs/libmoe/libmoe-1.5.8-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild b/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild
new file mode 100644
index 000000000000..01e7722e7012
--- /dev/null
+++ b/dev-libs/libmoe/libmoe-1.5.8-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Multi octet character encoding handling library"
+HOMEPAGE="http://pub.ks-and-ks.ne.jp/prog/libmoe/"
+SRC_URI="http://pub.ks-and-ks.ne.jp/prog/pub/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( libmoe.shtml )
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-gcc5.patch" # taken from Debian
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/^PREFIX=/s:=.*:=${EPREFIX}/usr:" \
+ -e "/^LIBSODIR=/s:=.*:=\$\{PREFIX}/$(get_libdir):" \
+ -e "/^MANDIR=/s:=.*:=\$\{PREFIX}/share/man:" \
+ -e "/^CF=/s:=:=${CFLAGS} :" \
+ -e "/^LF=/s:=:=${LDFLAGS} :" \
+ -e "s:=gcc:=$(tc-getCC):" \
+ -e "/^AR=/s:=ar:=$(tc-getAR):" \
+ Makefile || die
+}