summaryrefslogtreecommitdiff
path: root/dev-libs/libmateweather/libmateweather-1.26.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-01 23:49:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-01 23:49:35 +0000
commitf8ce9f2b903374606b4f44deb7727aca194ef970 (patch)
tree60b15bcfcc2e2f638e9307f40ecbabb9ca911b1c /dev-libs/libmateweather/libmateweather-1.26.3.ebuild
parentc16ac3f2fa4ccc7440fd13db1e5872a3e319f48c (diff)
gentoo auto-resync : 01:01:2024 - 23:49:35
Diffstat (limited to 'dev-libs/libmateweather/libmateweather-1.26.3.ebuild')
-rw-r--r--dev-libs/libmateweather/libmateweather-1.26.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libmateweather/libmateweather-1.26.3.ebuild b/dev-libs/libmateweather/libmateweather-1.26.3.ebuild
new file mode 100644
index 000000000000..d85e7e444d90
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.26.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.56:2
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.54:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ --disable-icon-update
+}