summaryrefslogtreecommitdiff
path: root/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-08 15:45:39 +0100
commitd5599da3055bf9b900513a61c3c6e4bdbb524503 (patch)
treeb64a792286dd490c9d4fc2c46bbbaa64804efc61 /dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
parentcfeee79886441e92c8ee094e45b9bcdc9c79137a (diff)
gentoo auto-resync : 08:06:2023 - 15:45:39
Diffstat (limited to 'dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild')
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
new file mode 100644
index 000000000000..a5e65f40f211
--- /dev/null
+++ b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library for generation and use of macaroons authorization credentials"
+HOMEPAGE="https://github.com/rescrv/libmacaroons"
+SRC_URI="https://github.com/rescrv/libmacaroons/archive/refs/tags/releases/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/json-c
+ dev-libs/libsodium
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}"/${PN}-releases-${PV}
+
+PATCHES=( "${FILESDIR}"/${P}-json-c.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-python-bindings --enable-json-support
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}