summaryrefslogtreecommitdiff
path: root/dev-libs/liblzw/liblzw-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /dev-libs/liblzw/liblzw-0.3.ebuild
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'dev-libs/liblzw/liblzw-0.3.ebuild')
-rw-r--r--dev-libs/liblzw/liblzw-0.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/liblzw/liblzw-0.3.ebuild b/dev-libs/liblzw/liblzw-0.3.ebuild
new file mode 100644
index 000000000000..ffb0f9291ca1
--- /dev/null
+++ b/dev-libs/liblzw/liblzw-0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="small C library for reading LZW compressed files (.Z)"
+HOMEPAGE="https://github.com/vapier/liblzw"
+SRC_URI="https://github.com/vapier/liblzw/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~s390 ~x86"
+IUSE="static"
+
+src_configure() {
+ econf --disable-werror $(use_enable static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}