summaryrefslogtreecommitdiff
path: root/dev-libs/liblouis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /dev-libs/liblouis
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'dev-libs/liblouis')
-rw-r--r--dev-libs/liblouis/Manifest2
-rw-r--r--dev-libs/liblouis/liblouis-3.29.0.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/dev-libs/liblouis/Manifest b/dev-libs/liblouis/Manifest
index 2cff72f5d9e4..9c0bdbf96f68 100644
--- a/dev-libs/liblouis/Manifest
+++ b/dev-libs/liblouis/Manifest
@@ -1,5 +1,7 @@
DIST liblouis-3.23.0.tar.gz 16738612 BLAKE2B b4508d27eaa9669bb2a1fbaac55edb3a85d3d2df18a8b26f4c9c396579b04614da3b3bcd6af45459d9129d2b81a920262dcb8fef7bee4290752174411fd66109 SHA512 25819758fc987ed378c439c5d40efd2692247a6020a40e5909320021e518e0518f5b022dda4ea5c7006a0f1ce2a4225d4ee1404560987bb2dd83504d58aa09db
DIST liblouis-3.25.0.tar.gz 16939419 BLAKE2B f67dc1ee3aa9eb32fcf0693b3a31d40c56f048b393785011ec2b4c61611a3ab67d181d1e76148c489e443e3b0c4d5f7846ac1b4810ffa2c6a6e1d081cceab6ae SHA512 4e6456f30e845b955e98346cb94bdd4eaa6aff30f3e29fbd4e91c5bb58d1182c679fbf8afa27d7031c80d5755ae8567b830fa57c175522a038ef18d1bdc0707d
+DIST liblouis-3.29.0.tar.gz 17073843 BLAKE2B b7735f4c59c46cef55f4748b54395b95f4f3623be37bd42bbed4249232d5ab4ad966e4f08945f91516be30f19735ed774411cfe4bc8e1c7822f04af2d0b0db27 SHA512 c2f51686e869921658a95a58102799ebcf45da9b73f7d81912462451236134be7c148b78f35a1e0586cd349bbcb62238218c9ae547092bed9303238c22963589
EBUILD liblouis-3.23.0.ebuild 1759 BLAKE2B 912ab7776d3d0e4dad6906c993f4bc3dc47466ebb286705edac8205ec188187897769881181026839c2057ea6c11cc433d6a648fa99af5fd8a58c305ce177b58 SHA512 c2e7c1ff3ad718f1ebc651dcc87c516a96599468f9d3f3605a4715fccc2e6bc0353e77c409b6c5355ad6080fa5a9523a12a9e69040b52ac621e07d4c95a5e3d4
EBUILD liblouis-3.25.0.ebuild 2418 BLAKE2B d91afdba655494c4e8c7f350ae675d6a4647b52d2732d418b9cd2bc3279dae85726d472b9d0d3d1c4190975eda3f3dc2362e4136f1a3f5b5035b6341ccf93592 SHA512 cb5ff4d9424be649235e31cf3af3e84a5386bcd293dd87b60a7d24d06360a44687ad5444b0dcd435dc27b39f2fbfe6de49fead1dc000edae850825813d6a6a95
+EBUILD liblouis-3.29.0.ebuild 2836 BLAKE2B 116a70679950f694f132df8a9cbd64e97a4b7795107b7cb65aba516ccd19e0a19a10a85142075e02393c10b82a3e244624a39ef890621c485b5f69307bd262d6 SHA512 bd8ec8938709b5a0dff2d9a221f5ca086be6cc13b77078757baba9e4f9b89fb001b230b4c5712085e87c6696c2c52ffac28ee53ed69bdda1619687189e4bbf3e
MISC metadata.xml 352 BLAKE2B 5c562663af1cb8a830ef585416cd7dbd4977393310fb2216ac6fb5bbaa594ad4fb144bac1a49d161e5946978cbc28acdbaf5d59e781da5438d7116f34c259290 SHA512 23c7fd40c40c8e574d995d0fdbe56242e9b1874d576ba8a34cee80e3c3e41785e782ca37fb3f89665c24d5857cb956b70c9219dc3dc35cb209f947f0b267c4be
diff --git a/dev-libs/liblouis/liblouis-3.29.0.ebuild b/dev-libs/liblouis/liblouis-3.29.0.ebuild
new file mode 100644
index 000000000000..fdd585cad1e6
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-3.29.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An open-source braille translator and back-translator"
+HOMEPAGE="https://github.com/liblouis/liblouis"
+SRC_URI="https://github.com/liblouis/liblouis/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/20" # follows LIBLOUIS_CURRENT in configure.ac
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# texlive-core for patgen which is required by lou_maketable
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/texlive-core
+ test? ( dev-libs/libyaml )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${DISTUTILS_DEPS}
+ ${PYTHON_DEPS}
+ sys-apps/help2man
+"
+
+src_prepare() {
+ default
+
+ #1. bug #913705
+ #2. Use correct python version
+ sed -i \
+ -e "s|\$CURDIR/lou_maketable.d|${EPREFIX}/usr/libexec/lou_maketable|" \
+ -e "s|python3|${EPYTHON}|" \
+ tools/lou_maketable.d/lou_maketable.in || die
+
+ pushd python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+}
+
+src_configure() {
+ # -fanalyzer substantially slows down the build and isn't useful for
+ # us. It's useful for upstream as it's static analysis, but it's not
+ # useful when just getting something built.
+ export gl_cv_warn_c__fanalyzer=no
+
+ econf --enable-ucs4 $(use_with test yaml)
+}
+
+src_compile() {
+ default
+
+ pushd python > /dev/null || die
+ # setup.py imports liblouis to get the version number,
+ # and this causes the shared library to be dlopened
+ # at build-time. Hack around it with LD_PRELOAD.
+ # Thanks ArchLinux.
+ LD_PRELOAD+=":${S}/liblouis/.libs/liblouis.so" distutils-r1_src_compile
+ popd > /dev/null || die
+}
+
+src_test() {
+ default
+
+ pushd python > /dev/null || die
+ LD_PRELOAD+=":${S}/liblouis/.libs/liblouis.so" distutils-r1_src_test
+ popd > /dev/null || die
+}
+
+python_test() {
+ local -x LOUIS_TABLEPATH="${S}"/tables
+ "${EPYTHON}" tests/test_louis.py || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_scriptinto /usr/libexec/lou_maketable
+ python_doexe ../tools/lou_maketable.d/*.py
+}
+
+src_install() {
+ pushd python > /dev/null || die
+ LD_PRELOAD+=":${S}/liblouis/.libs/liblouis.so" distutils-r1_src_install
+ popd > /dev/null || die
+
+ # These need to be after distutils src_install, or it'll try to install them from under python/ as well
+ DOCS=( README AUTHORS NEWS ChangeLog doc/liblouis.txt )
+ HTML_DOCS=( doc/liblouis.html )
+ default
+
+ # bug #913705
+ mkdir -p "${ED}"/usr/libexec/lou_maketable || die
+ mv "${ED}"/usr/bin/lou_maketable.d/*.{mk,pl,sh} "${ED}"/usr/libexec/lou_maketable/ || die
+ rm -r "${ED}"/usr/bin/lou_maketable.d || die
+
+ find "${ED}" -name '*.la' -delete || die
+}