summaryrefslogtreecommitdiff
path: root/dev-libs/liblouis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-libs/liblouis
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-libs/liblouis')
-rw-r--r--dev-libs/liblouis/Manifest2
-rw-r--r--dev-libs/liblouis/liblouis-3.17.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/liblouis/Manifest b/dev-libs/liblouis/Manifest
index f85be8cf6d1c..7953be10fad8 100644
--- a/dev-libs/liblouis/Manifest
+++ b/dev-libs/liblouis/Manifest
@@ -1,3 +1,5 @@
DIST liblouis-3.13.0.tar.gz 14683684 BLAKE2B 9596fac30ee8512498826ea11c3fe4d9dfba6706166938852242533f1fadde9ca8e363ea1364ebb4266b366ee49863d84ad757f8634d90e48dd8c562c31e9e8d SHA512 68f0205dc55a106c5707f959c1c0d3c121dfe62f263a664e6bec0780bee65cce2fb5d7033ae1c8312d1d79f7ccaf650af71906e8651b60f11219758e41051b61
+DIST liblouis-3.17.0.tar.gz 14868166 BLAKE2B 2edc5ef4366e29080d0d138fe45d946730e04dea278a14751106a25862f6266fe0fda492e12f4d2aa7d26d7277a11dfa2eaf8be39cdeffbcf83f2c143922e6d6 SHA512 9511e0f76ef6def3fa30f0bce4df188b2a11251e8ced0a76a92e172026e6751bc19b2c8ccd5789043b65398190a367bca03b3f1449344750e63ebd0fde60b4e3
EBUILD liblouis-3.13.0.ebuild 1743 BLAKE2B 488ab7006fac89c4304ba02924d8e24a99df1cbbacf18083a5a69367dbb9bd2af1b7aef6a132dde5f1b9ef06c05639aaec2356702336feaa2cc92f2b06a67eae SHA512 3d8a7ad11b920e767511611cf147abcff1144141d4afa1b90aade5e1b78659c04a792753e040c5776aa1ac30635985c8e8d0aaaec2ae64ae2b170b2fdf3bba02
+EBUILD liblouis-3.17.0.ebuild 1749 BLAKE2B 986987f2ccd8dc45f221485058d06fa1b59a63476dca61eb6e48a0170fb2489212e2e44282d0831b0968de5b1f96e959ac6b98044be2364587a0ef23526b7903 SHA512 f3f8a40d5a999b442de6a45d1d1822c7778574474a546755bca53bdaeb1f1b60acab2a42a6e7846a31785329e9c47a7cbbf55e2572614445852d5044289d2ee7
MISC metadata.xml 351 BLAKE2B 0fa7c957682fe363ddd29442ae153152469cc64ebf9005361c4b82f180c380485adf0b04467b147a441c6656ddcc9e44967fd692ed9f835d70653dbae9b9be1a SHA512 377a2d9ea4bc6007a60fcaf0284bd47af78b6fe2c901916f9cd7d6ab0f7a5225baf7314b47b0c3b00cd162278f910206bd99469bdef0165cd6e19c1eff73714d
diff --git a/dev-libs/liblouis/liblouis-3.17.0.ebuild b/dev-libs/liblouis/liblouis-3.17.0.ebuild
new file mode 100644
index 000000000000..6ea877ba7b42
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-3.17.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1
+
+DESCRIPTION="An open-source braille translator and back-translator"
+HOMEPAGE="https://github.com/liblouis/liblouis"
+SRC_URI="https://github.com/liblouis/liblouis/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/20"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/help2man
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/setuptools-42.0.2[${PYTHON_USEDEP}]
+ )
+ test? ( dev-libs/libyaml )
+"
+
+src_prepare() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ distutils-r1_src_prepare
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-ucs4 \
+ --disable-static
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ # setup.py imports liblouis to get the version number,
+ # and this causes the shared library to be dlopened
+ # at build-time. Hack around it with LD_PRELOAD.
+ # Thanks ArchLinux.
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so'
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ if use python; then
+ pushd python > /dev/null
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so' \
+ distutils-r1_src_install
+ popd > /dev/null
+ fi
+
+ # These need to be after distutils src_install, or it'll try to install them from under python/ as well
+ DOCS=( README AUTHORS NEWS ChangeLog doc/liblouis.txt )
+ HTML_DOCS=( doc/liblouis.html )
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}