summaryrefslogtreecommitdiff
path: root/dev-libs/liblogging/liblogging-1.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-libs/liblogging/liblogging-1.0.6.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-libs/liblogging/liblogging-1.0.6.ebuild')
-rw-r--r--dev-libs/liblogging/liblogging-1.0.6.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/dev-libs/liblogging/liblogging-1.0.6.ebuild b/dev-libs/liblogging/liblogging-1.0.6.ebuild
index 920b54472c5a..5974f3ede556 100644
--- a/dev-libs/liblogging/liblogging-1.0.6.ebuild
+++ b/dev-libs/liblogging/liblogging-1.0.6.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
inherit autotools
@@ -12,20 +12,16 @@ SRC_URI="http://download.rsyslog.com/liblogging/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0/0"
KEYWORDS="amd64 arm ~arm64 hppa x86"
-IUSE="rfc3195 static-libs +stdlog systemd"
+IUSE="rfc3195 +stdlog systemd"
RDEPEND="systemd? ( sys-apps/systemd )"
-
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
DOCS=( ChangeLog )
src_prepare() {
default
-
eautoreconf
}
@@ -34,6 +30,7 @@ src_configure() {
$(use_enable rfc3195)
$(use_enable stdlog)
$(use_enable systemd journal)
+ --disable-static
)
econf "${myeconfargs[@]}"
@@ -41,6 +38,5 @@ src_configure() {
src_install() {
default
-
- find "${ED}"usr/lib* -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}