summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /dev-libs/libinput
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest2
-rw-r--r--dev-libs/libinput/libinput-1.11.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index ac81d0460a94..5b46aeb508c4 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,5 +1,7 @@
DIST libinput-1.10.6.tar.xz 495536 BLAKE2B 3f23808635406eeb66cd6b4ce2a2dbaed69ee0917045f75ad262a59702d72923493b6faa7951ea3f7cc2591d4c9e1fc49cffc53b6dfbcb2aadc7b9f40c20517b SHA512 b76963c3429c5590ee04f1da94d08775c8bb8584830e678804fb1d4cf0e2af84826782eae71fdd57492461f85df87ac2fc940c280b0672c75cd81d5f34702fe4
DIST libinput-1.10.7.tar.xz 494648 BLAKE2B ddcbe5f54b90f8291c16e5912fa3d673fb2c66f0247c9d771f7c2dfeeef9b51404f31d7ac99cfd20b37e1d01d6b2b3bc95155ab6581c6a94e922e153d9098892 SHA512 b102b8065ceed7511ad26efba34d5d9b0c13f0f7aaa882bb21501f7a5166f4cbe140fcbb488e90e6880bd47bb2b27667a4d6aa79b8726269fa1337897034a684
+DIST libinput-1.11.0.tar.xz 485976 BLAKE2B f0bd88463b6aba7bfcf80d3354e53fe86e367a29055e295621d84175720544af035cc6303a2777d6ac4535d4706c41fa435a3a5a3abd20eb9ad33366dad4eae8 SHA512 382a6c9ec4aaf13ac209ee5a7f507c7a6d2dd399c5104703ac7c6ac62fb3f393de6f4e15d7895b18c8b8d845ce8fc1f551a90aa7532f0de4cc17e57a09cfe857
EBUILD libinput-1.10.6.ebuild 1441 BLAKE2B 3310fc527a72be6d0561091a4fd20cf637b66651e6668bb12357feb3f92f52c570db613bbcb45398ea9e38bbb685a82faeaf6a0299acdf156d3f7db01e80bfd1 SHA512 2281dfa10a76434333a54fa69c444a6a54b89b797344646ca4316e86b7292ccfa9047136f3f62dc631988ce1a4d92f35514915c8829fe469f1a35f454a772002
EBUILD libinput-1.10.7.ebuild 1441 BLAKE2B 3310fc527a72be6d0561091a4fd20cf637b66651e6668bb12357feb3f92f52c570db613bbcb45398ea9e38bbb685a82faeaf6a0299acdf156d3f7db01e80bfd1 SHA512 2281dfa10a76434333a54fa69c444a6a54b89b797344646ca4316e86b7292ccfa9047136f3f62dc631988ce1a4d92f35514915c8829fe469f1a35f454a772002
+EBUILD libinput-1.11.0.ebuild 1528 BLAKE2B e3daf3472281d8a9dee058de497bcb2c0155f273a89fd5cf7334fbe40486e540e02d793bfa30d08342a1123aba2936dad4a921132d6cf802541635f6836cf8c7 SHA512 d601843c5a1a729de144c7b63a2a8efa3a4ff7ce60727a964a1d48419ef7a8c1b7b3bbd54853f71707a1071613cee9fba7434d91960236b467c7086b8224c4fd
MISC metadata.xml 340 BLAKE2B b555474c5acc545a4a81d86b590620ed4eab35e091d012d740f3d0f08add99bc0b5d09db251c03e1191df719135c92251d98849944fe41f76336526a96f9ae7a SHA512 04b1dc52c0db95a09aeb061ea0bc579f83ad5971dcdb20cf61bb08ed37bf56999f784db75e6ec2b6cd47e57976c7e0651ffb040b052dd0f5ac8e1a679bee8c09
diff --git a/dev-libs/libinput/libinput-1.11.0.ebuild b/dev-libs/libinput/libinput-1.11.0.ebuild
new file mode 100644
index 000000000000..0635ed1b8faf
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.11.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit meson udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ -Ddocumentation="$(usex doc true false)"
+ -Dlibwacom="$(usex input_devices_wacom true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/html/.
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}
+
+pkg_postinst() {
+ udevadm hwdb --update --root="${ROOT%/}"
+}