summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 07:05:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 07:05:54 +0000
commit13ec12ad28bc2ce6e2902be1d571befcca2b3f60 (patch)
tree7c606c326ffa4095258ba77370fe2cad7aff49a8 /dev-libs/libinput
parentb7819d03d7312d3d8d12b49738aa417f35f6e18a (diff)
gentoo auto-resync : 22:11:2022 - 07:05:54
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest2
-rw-r--r--dev-libs/libinput/libinput-1.22.0.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 90589953f93a..52cfced3aa23 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,5 @@
DIST libinput-1.21.0.tar.gz 988650 BLAKE2B 54c63beeff8dee93a52774220b45321d8a94261687b463319fbae9246331b532be7995a5b32c30425b9d0708b2ba69d4b4e83e8dc7ecebe6fb1237b723a266b6 SHA512 510273d68f2d4cfa61564a706b1f334f6bfca0d1c8faf0bb8aa656cf3fbd5e38d79d6fbaa01a20d38bc15777c9afc341e4ed08d35ef367ef3803ce788cbc4a0e
+DIST libinput-1.22.0.tar.bz2 796133 BLAKE2B 3552f0a9ab0690969c5a7d62882733aa7bcaed1c0e97ff3606f58558c235cb67e3c81bc5a277273d26e6847438acccfc942d2fbec312e9a0d121d8ea21896496 SHA512 62cc36845daa7bc4b8477dd71abe629309683a93de753382a90e8466915e2b96b9c6914b431747d3462c15d8ab42bc70ee755800eec60c4ad7e9f3b4f7dba76d
EBUILD libinput-1.21.0-r1.ebuild 2289 BLAKE2B c89e242476aef8f5eda9db495a361a9118dfa385d42cc620cbef880436f61b773e9962effe4443a0915342a196c497721da5b1b5651e969299ad225024d5898d SHA512 8dc50c92765e5877c1d1d0bff8fe002f190b835b02d8f90d6d18c14a4a1602197e7f5854ab284f47c198c1c73e83f05c85bae56b105bb29026560141429275a4
+EBUILD libinput-1.22.0.ebuild 2179 BLAKE2B 90d939773a94fd7d9c2647aedf4aa7981df5b984d00da962bc8b1f6bf1926016bebb77b92b9b3db1af021f7e7f09242c38781c0fb90a1b70be2d1edd3f4e40e5 SHA512 8ab2f4c6ead05ecf089faa09599b20ea288d8caf77771fa0dedf3252164170656b9209f6a9eec54cf52283d5f8239ed0a69a2af110cd28d9aca91f1cc20bbb67
MISC metadata.xml 339 BLAKE2B c649f0ffaad1b1dc76c3d3184d95356b2925f642ff6b96c3eba0c31a1d96c3d9b741c1348f8ec90d02428c30a836872fe4e42e7ab5f5e5197f4a787f9147a1a8 SHA512 e9aeca6cc4451ab5b622f597f8debaecfdc672244e5e0b687ac294c20009ba42fb2ccc45e7016a2427312e1c768259005e0a7ff53026087570382652ec23cb60
diff --git a/dev-libs/libinput/libinput-1.22.0.ebuild b/dev-libs/libinput/libinput-1.22.0.ebuild
new file mode 100644
index 000000000000..4457b5e6d2e8
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.22.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2014-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit meson optfeature python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/10"
+if [[ $(ver_cut 3) -lt 900 ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.27:= )
+ >=dev-libs/libevdev-1.9.902
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? ( dev-util/valgrind )
+
+python_check_deps() {
+ python_has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ python_has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ python_has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s@, '-Werror'@@" -i meson.build || die #744250
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ $(meson_use test tests)
+ -Dudev-dir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ optfeature "measure and replay tools" dev-python/python-libevdev
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}