summaryrefslogtreecommitdiff
path: root/dev-libs/libgweather
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 23:01:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 23:01:48 +0100
commit5017c48e54de7e3dcebd1db96598cf0a07b21f16 (patch)
tree5daf82c5678eb5c4cafc2f49503dfed11968e671 /dev-libs/libgweather
parent7b830374520118e805fdd214530a389653750f51 (diff)
gentoo auto-resync : 16:09:2023 - 23:01:48
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest2
-rw-r--r--dev-libs/libgweather/libgweather-4.4.0.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index 2e8ebbfa360b..558d1ddc0b56 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1,3 +1,5 @@
DIST libgweather-4.2.0.tar.xz 2752164 BLAKE2B 9cc51363d6a2a09497269760701e0e0c1beb68c0096262fb6e2885414f838b41c151df7b057def457fdd49f9036d853ab624a9683a5cf57bbdefaed5376fe69f SHA512 cd95c6714575c0afc52455bb99c9116af27716868648debe0e5309904cfaf7516cf2379e415b3d9dd57b5dd223bae8e8acbaf705a3867dad8f75aec22eea908e
+DIST libgweather-4.4.0.tar.xz 2808680 BLAKE2B d3bfabd7936a5dc5f6f77cbb5acb3a7b80cebe1f08ff48582e1609cad04051ce8b84959c27576c928233e4625db8831c99d049378908cbe562b48221b6f37392 SHA512 dd232d36b168132a7c7cf06ffff16e88eb6e3e9e003e39b975df3d294ada401ab7d34de386dcc53452de6b0f8c68ff7f0cf6a94492e353828e00d4a1204b5d00
EBUILD libgweather-4.2.0.ebuild 1971 BLAKE2B 2e4ac0a65feda6757fb8c19c20c9613f9ee3269751f9aa06f7be6c4863ae62c07481ec57ab8b9e6d69c075e1013dd200d041563477e9ab8475a7bcd84330542b SHA512 6463ef5b32c2bab03eb988e1c4ae26d4fc1e14376e0fa4940aca9a7089ca0a5ada9b401f4953c2a545b3a30a4f48940ec3a245274079d9c795d59857272b614c
+EBUILD libgweather-4.4.0.ebuild 1975 BLAKE2B 56559d5500eadd945f7059dfc959b0e6778aa37f11edca66452fc7059a2263d974ae690b169f5add6805fea41a3242fbb866bcb2fb29809ade851527a9ae842c SHA512 2d7eefcfc1ee68bd226405e622bfb8c769f43e76a2f46f26a365dad0c8c5fe077838ec4d0c9a814b9a24eb77500b2a893f90dafc765f024154c38bd16a37685e
MISC metadata.xml 352 BLAKE2B 3726dfdf7269138db7992dbab72db960ed2362a8c753362376f28fa37e0849ef89f74b132dea4c63120dfb777f27566aea12f5dc92ddbeeb5a3b8139d4feeb9c SHA512 06dcfdd1ba301e34b2b9a23f3cdb5a686daa8fcc7a2caa8ac921eade3e805589ba2bb148da5f64f95f93d62dda71b5e19f37b33f1e35201c61bd8e0bb996bbf4
diff --git a/dev-libs/libgweather/libgweather-4.4.0.ebuild b/dev-libs/libgweather/libgweather-4.4.0.ebuild
new file mode 100644
index 000000000000..ceccb46337ad
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-4.4.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="4/4-0" # subslot = 4-(libgweather-4 soname suffix)
+
+IUSE="gtk-doc +introspection test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ vala? ( introspection )
+ gtk-doc? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=net-libs/libsoup-2.99.2:3.0
+ sci-geosciences/geocode-glib:2
+ >=dev-libs/libxml2-2.6.0:2
+ dev-libs/json-glib
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gi-docgen-2021.6 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
+ vala? ( $(vala_depend) )
+"
+
+python_check_deps() {
+ python_has_version -b "dev-python/pygobject[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+ use vala && vala_setup
+ # The metar test requires network access
+ if has network-sandbox ${FEATURES}; then
+ sed -i -e '/metar/d' libgweather/tests/meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use vala enable_vala)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use test tests)
+ -Dsoup2=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/libgweather-4.0 "${ED}"/usr/share/gtk-doc/ || die
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}