summaryrefslogtreecommitdiff
path: root/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild')
-rw-r--r--dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild b/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
deleted file mode 100644
index 83669f2db358..000000000000
--- a/dev-libs/libgpiod/libgpiod-1.6.3-r3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info multilib-minimal
-
-DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
-HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
-SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-# Reflects the ABI of libgpiod.so
-SLOT="0/2"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-IUSE="static-libs +tools cxx python test"
-RESTRICT="!test? ( test )"
-
-# --enable-tests enable libgpiod tests [default=no]
-# --enable-bindings-cxx enable C++ bindings [default=no]
-# --enable-bindings-python
-
-pkg_setup() {
- CONFIG_CHECK="~GPIO_CDEV_V1"
- linux-info_pkg_setup
-}
-
-multilib_src_configure() {
- local myconf=(
- $(use_enable tools)
- $(use_enable cxx bindings-cxx)
- $(use_enable test tests)
- $(multilib_native_use_enable python bindings-python)
- )
-
- if ! multilib_is_native_abi; then
- myconf+=(
- --disable-tools
- )
- fi
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-}
-
-multilib_src_install() {
- default
-
- find "${D}" -name '*.la' -type f -delete || die
-
- if ! use static-libs; then
- find "${D}" -name "*.a" -delete || die
- fi
-}