summaryrefslogtreecommitdiff
path: root/dev-libs/libgit2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-libs/libgit2
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-libs/libgit2')
-rw-r--r--dev-libs/libgit2/Manifest2
-rw-r--r--dev-libs/libgit2/libgit2-0.28.5.ebuild72
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-libs/libgit2/Manifest b/dev-libs/libgit2/Manifest
index 8fee5219dcb9..114b325a18dd 100644
--- a/dev-libs/libgit2/Manifest
+++ b/dev-libs/libgit2/Manifest
@@ -1,5 +1,3 @@
-DIST libgit2-0.28.5.tar.gz 4998481 BLAKE2B 71a3502af125a3d1c91700539d5e235a62922b32ca5e62288581b496f4cb680c01bfe70ae092ab730fc45df1dd96c2c9167f51d551a50acd57c857b4ea07634d SHA512 abfea885f46444b0304ae57c32c06f4252afb0093c924da5e1ba10aaed952824d1b84036adb79b5b8ad8bea56a6331a51c62f3b9839aead16c7b26cb4554b53a
DIST libgit2-1.0.1.tar.gz 5312878 BLAKE2B 7eb97bb97d66240ce135e21d348f6dea0c5626992b608f8944b75f9bae5de933fffa07edd536c0353841f8d02c950feec1451008003e35f53554f3c59b069a7f SHA512 7c307822b22e3771e5e908b115600310f7901b3250287532c498003b25a5b1e007bfa23592f16ec4d83c1567a9213710526f78cab7c120316e9a8fc74c5e57a9
-EBUILD libgit2-0.28.5.ebuild 1650 BLAKE2B 859432292f7c913953d0c23454dd1c463e44e2696308b29292a4e9b26876c261150d8cc36da549769b1384e8d39eadb1ba11f8abebf20876dd190e72282abcab SHA512 64648a55fe4c25d46fcc99dce81012b3ee586202ae1925a0704b052d73985cd14ceaa0b06988ae2a320fd32c971667caec06013cb03cf25c7ff34b47c7fa235a
EBUILD libgit2-1.0.1.ebuild 1701 BLAKE2B df293ea3fae126e98feaa885df36fa4cfc249d1645e77672bd23b425302a62515abad2a1a48f7f7ce3c01d357c76bb8bf5dc6e7d3312e5fa6d890227adbfb22d SHA512 0fd2c229b1a21be488e7d9786cc59492257ef8e1f51156aeb7ce78e5e3a8f99bbff1c61145becd5c5b4c0c28fb2bf6a31ffd44059fa1201397afd996bf4c9b5b
MISC metadata.xml 915 BLAKE2B 1882bdcfaee50de784b4aebeaaad4f04ff3f2385721b354ed685f3353ea92b83344559905cff5a9adc2a316b684079b64d9930f14081c257c8066dd7d4c89a33 SHA512 5b6f2239f656f490b0961788f8047662fc00ee10bc5ad9ee3a326313285cd29514c1eda54d17b878abef3d73034f997aa814a64ff496dcbe9f05ef4708825c35
diff --git a/dev-libs/libgit2/libgit2-0.28.5.ebuild b/dev-libs/libgit2/libgit2-0.28.5.ebuild
deleted file mode 100644
index 567e2678a2d7..000000000000
--- a/dev-libs/libgit2/libgit2-0.28.5.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake python-any-r1
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.org"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/28"
-IUSE="examples gssapi libressl +ssh test +threads trace"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-libs/zlib
- net-libs/http-parser:=
- gssapi? ( virtual/krb5 )
- ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${P/_/-}
-
-src_configure() {
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- -DBUILD_CLAR=$(usex test)
- -DENABLE_TRACE=$(usex trace)
- -DUSE_GSSAPI=$(usex gssapi)
- -DUSE_SSH=$(usex ssh)
- -DTHREADSAFE=$(usex threads)
- )
- cmake_src_configure
-}
-
-src_test() {
- if [[ ${EUID} -eq 0 ]] ; then
- # repo::iterator::fs_preserves_error fails if run as root
- # since root can still access dirs with 0000 perms
- ewarn "Skipping tests: non-root privileges are required for all tests to pass"
- else
- local TEST_VERBOSE=1
- cmake_src_test -R offline
- fi
-}
-
-src_install() {
- cmake_src_install
- dodoc docs/*.{md,txt}
-
- if use examples ; then
- find examples -name '.gitignore' -delete || die
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}