summaryrefslogtreecommitdiff
path: root/dev-libs/libgit2/libgit2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-libs/libgit2/libgit2-9999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-libs/libgit2/libgit2-9999.ebuild')
-rw-r--r--dev-libs/libgit2/libgit2-9999.ebuild26
1 files changed, 7 insertions, 19 deletions
diff --git a/dev-libs/libgit2/libgit2-9999.ebuild b/dev-libs/libgit2/libgit2-9999.ebuild
index d10065358a4f..5da98ce6f13c 100644
--- a/dev-libs/libgit2/libgit2-9999.ebuild
+++ b/dev-libs/libgit2/libgit2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
inherit cmake-utils python-any-r1
if [[ ${PV} == "9999" ]] ; then
@@ -18,18 +18,15 @@ DESCRIPTION="A linkable library for Git"
HOMEPAGE="https://libgit2.github.com/"
LICENSE="GPL-2-with-linking-exception"
-SLOT="0/27"
-IUSE="+curl examples gssapi libressl +ssh test +threads trace"
+SLOT="0/28"
+IUSE="examples gssapi libressl +ssh test +threads trace"
+RESTRICT="!test? ( test )"
RDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
sys-libs/zlib
net-libs/http-parser:=
- curl? (
- !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
- libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
- )
gssapi? ( virtual/krb5 )
ssh? ( net-libs/libssh2 )
"
@@ -38,15 +35,6 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
-DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
-
-src_prepare() {
- # skip online tests
- sed -i '/libgit2_clar/s/-ionline/-xonline/' tests/CMakeLists.txt || die
-
- cmake-utils_src_prepare
-}
-
src_configure() {
local mycmakeargs=(
-DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
@@ -55,7 +43,6 @@ src_configure() {
-DUSE_GSSAPI=$(usex gssapi)
-DUSE_SSH=$(usex ssh)
-DTHREADSAFE=$(usex threads)
- -DCURL=$(usex curl)
)
cmake-utils_src_configure
}
@@ -67,12 +54,13 @@ src_test() {
ewarn "Skipping tests: non-root privileges are required for all tests to pass"
else
local TEST_VERBOSE=1
- cmake-utils_src_test
+ cmake-utils_src_test -R offline
fi
}
src_install() {
cmake-utils_src_install
+ dodoc docs/*.{md,txt}
if use examples ; then
find examples -name '.gitignore' -delete || die