summaryrefslogtreecommitdiff
path: root/dev-libs/libg15/libg15-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-libs/libg15/libg15-9999.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-libs/libg15/libg15-9999.ebuild')
-rw-r--r--dev-libs/libg15/libg15-9999.ebuild47
1 files changed, 17 insertions, 30 deletions
diff --git a/dev-libs/libg15/libg15-9999.ebuild b/dev-libs/libg15/libg15-9999.ebuild
index a2faa8211176..3e7892e8cce0 100644
--- a/dev-libs/libg15/libg15-9999.ebuild
+++ b/dev-libs/libg15/libg15-9999.ebuild
@@ -1,51 +1,38 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-ESVN_PROJECT=g15tools/trunk
-ESVN_REPO_URI="https://svn.code.sf.net/p/g15tools/code/trunk/${PN}"
+EAPI=7
-inherit subversion base eutils autotools
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools subversion
+ ESVN_PROJECT=g15tools/trunk
+ ESVN_REPO_URI="https://svn.code.sf.net/p/g15tools/code/trunk/${PN}"
+else
+ KEYWORDS="amd64 ppc ppc64 x86"
+ SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
+fi
DESCRIPTION="The libg15 library gives low-level access to the Logitech G15 keyboard"
HOMEPAGE="https://sourceforge.net/projects/g15tools/"
-[[ $PV = *9999* ]] || SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE=""
-DEPEND="=virtual/libusb-0*"
-RDEPEND=${DEPEND}
-
-DOCS=( AUTHORS README ChangeLog )
-
-PATCHES=( "${FILESDIR}"/g15tools.patch )
-
-src_unpack() {
- if [[ ${PV} = *9999* ]]; then
- subversion_src_unpack
- fi
-}
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
src_prepare() {
- if [[ ${PV} = *9999* ]]; then
- subversion_wc_info
- fi
- base_src_prepare
- if [[ ${PV} = *9999* ]]; then
- eautoreconf
- fi
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-static
+ econf --disable-static
}
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}