summaryrefslogtreecommitdiff
path: root/dev-libs/libfido2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-libs/libfido2/files
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-libs/libfido2/files')
-rw-r--r--dev-libs/libfido2/files/libfido2-1.3.0-cmakelists.patch38
-rw-r--r--dev-libs/libfido2/files/libfido2-1.3.0-remove-openssh-middleware.patch45
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/libfido2/files/libfido2-1.3.0-cmakelists.patch b/dev-libs/libfido2/files/libfido2-1.3.0-cmakelists.patch
new file mode 100644
index 000000000000..a5a4b721ed0d
--- /dev/null
+++ b/dev-libs/libfido2/files/libfido2-1.3.0-cmakelists.patch
@@ -0,0 +1,38 @@
+diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
+index 71bc502..ac424d2 100644
+--- a/man/CMakeLists.txt
++++ b/man/CMakeLists.txt
+@@ -2,11 +2,12 @@
+ # Use of this source code is governed by a BSD-style
+ # license that can be found in the LICENSE file.
+
++include(GNUInstallDirs)
++
+ find_program(MANDOC_PATH mandoc)
+ message(STATUS "MANDOC_PATH: ${MANDOC_PATH}")
+
+ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+- find_program(GZIP_PATH gzip)
+ message(STATUS "GZIP_PATH: ${GZIP_PATH}")
+ endif()
+
+@@ -301,16 +302,16 @@ elseif(NOT MSVC)
+ foreach(f ${MAN_SOURCES})
+ if (${f} MATCHES ".1$")
+ install(FILES ${CMAKE_BINARY_DIR}/man/${f}
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/man/man1")
++ DESTINATION "${CMAKE_INSTALL_MANDIR}/man1")
+ elseif(${f} MATCHES ".3$")
+ install(FILES ${CMAKE_BINARY_DIR}/man/${f}
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/man/man3")
++ DESTINATION "${CMAKE_INSTALL_MANDIR}/man3")
+ endif()
+ endforeach()
+ foreach(i RANGE 0 ${MAN_ALIAS_MAX} 2)
+ math(EXPR j "${i} + 1")
+ list(GET MAN_ALIAS ${j} DST)
+ install(FILES ${CMAKE_BINARY_DIR}/man/${DST}.3
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man3)
++ DESTINATION ${CMAKE_INSTALL_MANDIR}/man3)
+ endforeach()
+ endif()
diff --git a/dev-libs/libfido2/files/libfido2-1.3.0-remove-openssh-middleware.patch b/dev-libs/libfido2/files/libfido2-1.3.0-remove-openssh-middleware.patch
new file mode 100644
index 000000000000..7dec27b861f9
--- /dev/null
+++ b/dev-libs/libfido2/files/libfido2-1.3.0-remove-openssh-middleware.patch
@@ -0,0 +1,45 @@
+diff --git a/README.adoc b/README.adoc
+index 8693417..023f2e9 100644
+--- a/README.adoc
++++ b/README.adoc
+@@ -71,18 +71,3 @@ KERNEL=="hidraw*", SUBSYSTEM=="hidraw", \
+ On Windows 1903 and newer versions, access to FIDO devices has been restricted
+ to applications using the operating system's native API. Use of *libfido2*
+ is still possible in privileged applications.
+-
+-=== OpenSSH Integration
+-
+-*libfido2* includes middleware allowing https://www.openssh.com[OpenSSH] to
+-talk to U2F/FIDO2 devices. Note that server support is required for
+-authentication. In a nutshell:
+-
+-==== Key Generation
+-
+- $ ssh-keygen -t [ecdsa-sk|ed25519-sk] -w /path/to/libsk-libfido2.so
+-
+-==== Authentication
+-
+- $ ssh-agent -P /path/to/libsk-libfido2.so
+- $ ssh-add -S /path/to/libsk-libfido2.so
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index 5f27e88..c44d1df 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -49,17 +49,9 @@ add_executable(fido2-token
+ ${COMPAT_SOURCES}
+ )
+
+-add_library(sk-libfido2 MODULE sk-libfido2.c)
+-set_target_properties(sk-libfido2 PROPERTIES
+- COMPILE_FLAGS "-DSK_STANDALONE -DWITH_OPENSSL"
+- OUTPUT_NAME sk-libfido2
+-)
+-
+ target_link_libraries(fido2-cred ${CRYPTO_LIBRARIES} fido2_shared)
+ target_link_libraries(fido2-assert ${CRYPTO_LIBRARIES} fido2_shared)
+ target_link_libraries(fido2-token ${CRYPTO_LIBRARIES} fido2_shared)
+-target_link_libraries(sk-libfido2 ${CRYPTO_LIBRARIES} fido2_shared)
+
+ install(TARGETS fido2-cred fido2-assert fido2-token
+ DESTINATION ${CMAKE_INSTALL_BINDIR})
+-install(TARGETS sk-libfido2 DESTINATION ${CMAKE_INSTALL_LIBDIR})