summaryrefslogtreecommitdiff
path: root/dev-libs/libffi-compat/libffi-compat-3.2.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-libs/libffi-compat/libffi-compat-3.2.1-r3.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-libs/libffi-compat/libffi-compat-3.2.1-r3.ebuild')
-rw-r--r--dev-libs/libffi-compat/libffi-compat-3.2.1-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libffi-compat/libffi-compat-3.2.1-r3.ebuild b/dev-libs/libffi-compat/libffi-compat-3.2.1-r3.ebuild
new file mode 100644
index 000000000000..7604ac448291
--- /dev/null
+++ b/dev-libs/libffi-compat/libffi-compat-3.2.1-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils libtool multilib multilib-minimal toolchain-funcs
+
+DESCRIPTION="a portable, high level programming interface to various calling conventions"
+HOMEPAGE="https://sourceware.org/libffi/"
+SRC_URI="ftp://sourceware.org/pub/libffi/libffi-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="6" # libffi.so.6
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug pax_kernel test"
+
+RDEPEND="!dev-libs/libffi:0/0" # conflicts on libffi.so.6
+DEPEND="test? ( dev-util/dejagnu )"
+
+DOCS="ChangeLog* README"
+
+PATCHES=(
+ "${FILESDIR}"/libffi-3.2.1-o-tmpfile-eacces.patch #529044
+ "${FILESDIR}"/libffi-3.2.1-complex_alpha.patch
+ "${FILESDIR}"/libffi-3.1-darwin-x32.patch
+ "${FILESDIR}"/libffi-3.2.1-complex-ia64.patch
+ "${FILESDIR}"/libffi-3.2.1-include-path.patch
+ "${FILESDIR}"/libffi-3.2.1-include-path-autogen.patch
+ "${FILESDIR}"/libffi-3.2.1-ia64-small-struct.patch #634190
+ "${FILESDIR}"/libffi-3.2.1-musl-emutramp.patch #694916
+)
+
+S=${WORKDIR}/libffi-${PV}
+ECONF_SOURCE=${S}
+
+src_prepare() {
+ default
+
+ sed -i -e 's:@toolexeclibdir@:$(libdir):g' Makefile.in || die #462814
+ elibtoolize
+}
+
+multilib_src_configure() {
+ use userland_BSD && export HOST="${CHOST}"
+ econf \
+ --disable-static \
+ $(use_enable pax_kernel pax_emutramp) \
+ $(use_enable debug)
+}
+
+multilib_src_install() {
+ dolib.so .libs/libffi.so.${SLOT}*
+}