summaryrefslogtreecommitdiff
path: root/dev-libs/libexplain/libexplain-1.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libexplain/libexplain-1.4-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libexplain/libexplain-1.4-r2.ebuild')
-rw-r--r--dev-libs/libexplain/libexplain-1.4-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libexplain/libexplain-1.4-r2.ebuild b/dev-libs/libexplain/libexplain-1.4-r2.ebuild
new file mode 100644
index 000000000000..d008b1f40c18
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.4-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3 LGPL-3"
+IUSE="static-libs"
+
+DEPEND="
+ sys-apps/acl
+ sys-apps/groff
+ app-text/ghostscript-gpl
+ >=sys-kernel/linux-headers-2.6.35"
+
+RDEPEND="
+ ${DEPEND}
+ sys-libs/libcap
+ sys-process/lsof
+ sys-libs/glibc"
+
+# Test fails with:
+# This is not a bug, but it does indicate where libexplain's ioctl support
+# could be improved.
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+ "${FILESDIR}"/libexplain-missing-defines.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp -v "${S}"/etc/configure.ac "${S}" || die
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+}