summaryrefslogtreecommitdiff
path: root/dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild')
-rw-r--r--dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild b/dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..3152a60d260b
--- /dev/null
+++ b/dev-libs/libevocosm/libevocosm-3.3.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A C++ framework for evolutionary computing"
+HOMEPAGE="http://www.coyotegulch.com/products/libevocosm/"
+SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/libcoyotl
+ dev-libs/libbrahe"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc47.patch"
+ epatch_user
+}
+
+src_configure() {
+ export ac_cv_prog_HAVE_DOXYGEN="false"
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ cd docs
+ doxygen libevocosm.doxygen || die "generating docs failed"
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dohtml docs/html/*
+}