summaryrefslogtreecommitdiff
path: root/dev-libs/libevdev/libevdev-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-libs/libevdev/libevdev-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-libs/libevdev/libevdev-9999.ebuild')
-rw-r--r--dev-libs/libevdev/libevdev-9999.ebuild40
1 files changed, 25 insertions, 15 deletions
diff --git a/dev-libs/libevdev/libevdev-9999.ebuild b/dev-libs/libevdev/libevdev-9999.ebuild
index ffddd6b0bd13..7fbea6d971fe 100644
--- a/dev-libs/libevdev/libevdev-9999.ebuild
+++ b/dev-libs/libevdev/libevdev-9999.ebuild
@@ -3,45 +3,55 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
-inherit multilib-minimal python-any-r1
+inherit meson multilib-minimal python-any-r1
DESCRIPTION="Handler library for evdev events"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
- inherit autotools git-r3
+ inherit git-r3
else
SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="doc static-libs"
+IUSE="doc test"
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
BDEPEND="
${PYTHON_DEPS}
doc? ( app-doc/doxygen )
- virtual/pkgconfig
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
"
-RESTRICT="test" # Tests need to run as root.
+RESTRICT="!test? ( test )"
-src_prepare() {
- default
- [[ ${PV} == 9999* ]] && eautoreconf
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
}
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
}
multilib_src_install() {
- default
- find "${D}" -name '*.la' -delete || die
- if use doc ;then
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ if use doc; then
local HTML_DOCS=( doc/html/. )
einstalldocs
fi