summaryrefslogtreecommitdiff
path: root/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild')
-rw-r--r--dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild b/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
new file mode 100644
index 000000000000..6ca1ecfdc703
--- /dev/null
+++ b/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Erasure Code API library written in C with pluggable Erasure Code backends."
+HOMEPAGE="https://bitbucket.org/tsg-/liberasurecode/overview"
+SRC_URI="https://github.com/openstack/liberasurecode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="sys-devel/autoconf
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --htmldir=/usr/share/doc/${PF} \
+ --disable-werror \
+ $(use_enable doc doxygen) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}