summaryrefslogtreecommitdiff
path: root/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
commit7b9f15840068dfaeea5684f8a1af1fe460dfa14c (patch)
tree112eea4497761c0227537330b58f9c7e0af3f9d8 /dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
parent0bff53119f08d677db6c1a991bd30741682a8a08 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild')
-rw-r--r--dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild b/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
new file mode 100644
index 000000000000..cde09e132201
--- /dev/null
+++ b/dev-libs/liberasurecode/liberasurecode-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Erasure Code API library written in C with pluggable Erasure Code backends."
+HOMEPAGE="https://bitbucket.org/tsg-/liberasurecode/overview"
+SRC_URI="https://github.com/openstack/liberasurecode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="sys-devel/autoconf
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --htmldir=/usr/share/doc/${PF} \
+ --disable-werror \
+ $(use_enable doc doxygen) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}