summaryrefslogtreecommitdiff
path: root/dev-libs/libebml/libebml-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-libs/libebml/libebml-1.4.1.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-libs/libebml/libebml-1.4.1.ebuild')
-rw-r--r--dev-libs/libebml/libebml-1.4.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/libebml/libebml-1.4.1.ebuild b/dev-libs/libebml/libebml-1.4.1.ebuild
new file mode 100644
index 000000000000..78a7706a34dc
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.4.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=YES
+ )
+
+ cmake_src_configure
+}