summaryrefslogtreecommitdiff
path: root/dev-libs/libe/libe-0.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/libe/libe-0.11.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/libe/libe-0.11.0.ebuild')
-rw-r--r--dev-libs/libe/libe-0.11.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/libe/libe-0.11.0.ebuild b/dev-libs/libe/libe-0.11.0.ebuild
new file mode 100644
index 000000000000..be48fd2433c4
--- /dev/null
+++ b/dev-libs/libe/libe-0.11.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+# bit messy at the moment, next release should fix it I hope
+RESTRICT="test"
+
+DESCRIPTION="Hyperdex libe support library"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND=">=dev-libs/libpo6-0.8.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/_strtoui64/strtoul/' e/convert.h || die
+}