summaryrefslogtreecommitdiff
path: root/dev-libs/libe/libe-0.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-libs/libe/libe-0.11.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-libs/libe/libe-0.11.0.ebuild')
-rw-r--r--dev-libs/libe/libe-0.11.0.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/dev-libs/libe/libe-0.11.0.ebuild b/dev-libs/libe/libe-0.11.0.ebuild
index be48fd2433c4..45011db72260 100644
--- a/dev-libs/libe/libe-0.11.0.ebuild
+++ b/dev-libs/libe/libe-0.11.0.ebuild
@@ -1,27 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit eutils
-
-# bit messy at the moment, next release should fix it I hope
-RESTRICT="test"
+EAPI=7
DESCRIPTION="Hyperdex libe support library"
-
HOMEPAGE="http://hyperdex.org"
SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
+# bit messy at the moment, next release should fix it I hope
+RESTRICT="test"
+
+RDEPEND="dev-libs/libpo6"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-IUSE=""
+PATCHES=( "${FILESDIR}"/${PN}-0.11.0-strtoul.patch )
+
+src_configure() {
+ econf --disable-static
+}
-RDEPEND=">=dev-libs/libpo6-0.8.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+src_install() {
+ default
-src_prepare() {
- sed -i -e 's/_strtoui64/strtoul/' e/convert.h || die
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}